Closed Bug 211107 Opened 18 years ago Closed 18 years ago

Tab'ed pages interfere with each others' status message displays

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 104532

People

(Reporter: atnak, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030629 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030629 Mozilla Firebird/0.6

Status messages of Tabs (File->New Tab kind) interfere with other tabs' status
displays.  For instance, I have one page loaded in one tab.  When I go to load
another page in another tab, the "Transferring data from ..." message for that
page will show as the already-loaded-tab's status as well.

Reproducible: Always

Steps to Reproduce:
1. Create a new window.
2. Press Ctrl-T to create another tab.  Now, there're two tabs, with the second
one being selected.
3. Type "www.microsoft.com" into the address bar then press Enter, quickly
followed by Ctrl-W.

Actual Results:  
Now, because you've closed the second tab (Ctrl-W) you're back to the first tab.
 However, the status message is still (if you closed the second tab quickly
enough) "Waiting for www.microsoft.com..." or "Transferring data from
www.microsoft.com...".



The Steps to Reproduce just describes a simple, easy method to reproduce --to
save myself typing.  It's only necessary to close the second tab so that people
with fast internet connections can see the obvious result.

Alternate method:
1. Create a new window.
2. Type "www.google.com" into the address bar then press Enter, quickly followed
by Ctrl-T.
3. Now, there're two tabs, with the second one being selected.  Wait a moment
for the first tab's Google page to load but notice that even though you're now
in the new tab, the status message is still "Transferring data from www.google.com".

Even after the first tab has finish loading Google, the "Transferring data.."
message is still statically present (at this point, even under the orginal,
Google page, tab).

*** This bug has been marked as a duplicate of 104532 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
verified DUPLICATE 2003-ß9-03
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.