Keyboard and Mouse freeze when loading/displaying many and/or large pages.

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Daniel Kinzler, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Sometimes, when I load multiple and/or large pages (in multiple tabs), the
keybord and mouse go *completely* dead for the entire OS (cursor does not move,
Keyboard-LEDs do not change on Caps-Lock and Num key) for about 5-20 sec.

I am not sure if this is due to the high load, or the page-size, or very complex
and/or buggy pages. I experienced this  problem repeatedly, but was not able to
reproduce it (i.e. i did not find a pattern).

This did *not* happen with Moz 1.2 though. My guess is that it has something to
do with a change in randering, layout, xul or java-script. I don't know which
though, that's why i files the bug under "Browser/General".

(sorry if this is a dupe. I looked for stuff with "Keyboard" and "Mouse" in it,
and found nothing similar...)

Reproducible: Sometimes

Steps to Reproduce:
1. Load many large pages at once, with a lot of pictures, tables, redirections
and java-script going on.
2. Repeat until The Bad Thing happens.

sorry that i can't be more precise. As stated above, i did not find a pattern.

Actual Results:  
keybord and mouse go *completely* dead for the entire OS (cursor does not move,
Keyboard-LEDs do not change on Caps-Lock and Num key) for about 5-20 sec.

Expected Results:  
Well, Moz should not block mouse or keyboard, i guess...

maybe you should just not do blocking/IO stuff in low-level
mouse/keyboard-handling-routines (looks loke an event-handler lockup to me).

Comment 1

15 years ago
I can confirm this on 1.5a trunk. This has been a problem for a long time since
blocking io reappears over and over again (people tend to repeat errors rather
than learning from them...).
Summary: Keyboard and Mouse freeze when loading/displaying many and/or large pages. → Keyboard and Mouse freeze when loading/displaying many and/or large pages.

Comment 2

14 years ago
This report isn't really useful as it is. We have dozens of bugs about various
places where the performance sucks and the I/O freezes up. They need to be
tackled on a case-by-case basis.
http://www.mozilla.org/quality/help/performance.html has information about how
you can help with this, if you want to reopen this bug and make it specific. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.