Cannot Verify Integrity of Saved File

VERIFIED DUPLICATE of bug 38121

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 38121
15 years ago
2 years ago

People

(Reporter: David E. Ross, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

The page at the cited URL contains my PGP keys.  Because of the sensitivity of
such data, I generated a detached PGP signature for the HTML file before
uploading it to my ISP's Web server.  On occasion, I save the page from the
server back onto my PC and recheck it against the signature.  With Mozilla 1.x,
the check fails, indicating someone has hacked my keys.  However, with Netscape
4.79, the check succeeds, indicating no such hack occurred.  

Apparently, the x0A (LF) at the end of each line of the ASCII HTML file on the
UNIX server is not being converted to x0D0A (CR-LF) for an ASCII file on a PC. 
I am unsure from reading RFC 1945 whether this conversion is required; it is not
prohibited by the RFC.  Since the reverse conversion is performed when FTP is
used to upload the file from a PC to a UNIX host, I would expect Mozilla to
perform this conversion.  


Reproducible: Always

Steps to Reproduce:
See "Details".  
Actual Results:  
See "Details".  

Expected Results:  
The page should be translated between the conventions used in the Web server
host and the conventions used in the client host (e.g., from UNIX to PC) without
any other alterations.  

This problem also prevents the use of checksums, MD5 hashed message digests, and
other forms of verification of file integrity when downloading or saving Web
pages.
In many cases, such a conversion will corrupt data, so doing it is hardly an
option unless you KNOW that the data involved is text data (you generally do not).

In any case, there are existing bugs on this.
Whiteboard: DUPEME
(Reporter)

Comment 2

15 years ago
Reference comment #1:

If there are already bugs on this, please indicate the numbers so that I can
track them.  
see bug 38121

*** This bug has been marked as a duplicate of 38121 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Verified.   For future reference, a status whiteboard of "DUPEME" means "This
bug is already filed but I cannot find the original bug number at the moment."
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.