Popup blocker allowed this one through

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: jayhenn, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Clicking on the "www.skyline-nissan.com" link for the first time brings up
www.skyline-nissan.com in addition to a popup after the popup blocker has been
enabled. (it sets a "showed" cookie after this which keeps the popup from
reoccurring)

In the javascript for the webpage, it uses this to pop up the add:

if (get_cookie("showed")==""){
      	   					newWindow =
window.open("http://stats.darkbluesea.com/extredir.php?do=2043", "exit",
"toolbar=0, location=0, directories=0, status=0, menubar=0,
scrollbars=1,resizable=1, left="+leftPos+", top="+topPos+"");
      	   					//newWindow =
window.open("http://stats.darkbluesea.com/extredir.php?do=2043", "exit",
"toolbar=1, location=1, directories=0, status=0, menubar=1,
scrollbars=1,resizable=1, left=0, top=0");
      	   					newWindow.blur();
      	   					document.cookie="showed=yes" 
      	   				}

Not sure if Moz's popup blocker is able to block these, but it sure'd be nice :)


Reproducible: Always

Steps to Reproduce:
1. Go to http://www.thefastandthefurious.net/fast_and_furious_skyline_gtr.htm
after clearing your cookies from that website (to get rid of the "showed" cookie)
2. Click on www.skyline-nissan.com in the center of the webpage (it might work
for any link, but I only tried the center one)
3. There ya go! One skyline-nissan.com window plus an ad window in addition to
what you started with




Expected Results:  
Blocked the ad!
hm... that looks like a very normal popup, and popup blocker blocks it just fine
for me...
(Reporter)

Comment 2

15 years ago
Just re-attempted after clearing settings and w/ multizilla installed.

The humorous part is that the window you want creates its own tab, while the
advertisement still spawns a new window.

-Jay

Comment 3

15 years ago
AOL seems to be getting some popups through now - the main site (
http://www.aol.com )spawns two windows and then a third upon leaving.  Not sure
if this is new or known.

Comment 4

15 years ago
ok - my mistake ... tried it on a different machine and it worked fine.

Comment 5

15 years ago
WFM, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.