Crash: accessing server with non-ascii chars [@ nsNntpService::GetFolderFromUri 4d70d17f]

RESOLVED WORKSFORME

Status

MailNews Core
Internationalization
--
critical
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: marina, Assigned: smontagu)

Tracking

({crash, regression})

Trunk
x86
All
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

15 years ago
seen with 20030624 branch build

i am crashing consistentyl while accessing the server that has a non-ascii char
in its name

To repro:
- subscribe to news.deinter.net;
- subscribe to the news group that has a non-ascii chars test_ñ;
- try to access one of the article on this server, you'll crash

stack to follow
(Reporter)

Updated

15 years ago
Keywords: crash, regression
(Reporter)

Comment 1

15 years ago
Incident ID:21494525
Summary: Crash: accessing server with non-ascii chars → Crash: accessing server with non-ascii chars (Signature = nsNntpService::GetFolderFromUri 4d70d17f)
(Reporter)

Updated

15 years ago
Summary: Crash: accessing server with non-ascii chars (Signature = nsNntpService::GetFolderFromUri 4d70d17f) → Crash: accessing server with non-ascii chars ( nsNntpService::GetFolderFromUri 4d70d17f)

Comment 2

15 years ago
*** Bug 214061 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
see attachment 1286228 for full stack on Linux.
Severity: normal → critical
OS: Windows XP → All
Summary: Crash: accessing server with non-ascii chars ( nsNntpService::GetFolderFromUri 4d70d17f) → Crash: accessing server with non-ascii chars [@ nsNntpService::GetFolderFromUri 4d70d17f]

Comment 4

15 years ago
Bug 217790 has same crash signature.
Product: MailNews → Core
Product: Core → MailNews Core
QA Contact: marina → i18n
WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090609 Lightning/1.0pre Shredder/3.0b3pre

I don't crash, though I don't see the characters properly, which is another (known) bug 105706.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsNntpService::GetFolderFromUri 4d70d17f]
You need to log in before you can comment on or make changes to this bug.