external link shows mail instead of browser

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Jason Ellis, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPME)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

When I click on a link external to Mozilla (link sent via IM, link on desktop,
etc.), Mozilla Mail is brought up instead of the browser.  See reproduction
steps for specifics...

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla browser and mail
2. Create a url link on the desktop (drag & drop from address bar)
3. Minimize mail
4. Minimize browser
5. Double-click on url link on the desktop

Actual Results:  
Result: Mail window restores and browser remains minimized

Note: If mail was minimized last, the browser window restores (correct 
behavior)

Expected Results:  
Browser window loading link restores

Some discussion on usenet with at least one confirmation at
http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&frame=right&th=33a6228617d04986&seekm=bdpm2g%2480s2%40ripley.netscape.com

Comment 1

14 years ago
I confirm this one. Mozilla 1.5
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

I notice the bug when using W2K's 'Active Desktop' and click a link. If I have
Mail running, it pops up. The link opens in the browser, but it remains
minimized, or in the background.

Since Active Desktop does not open on top of any other windows (it is a feature
of the DESKTOP) it is not too practical to keep the browser maximized (on 15
inch 1400x1050 pixel LCD) while looking at Active Desktop. However I have
experimented with this.

If the browser window is open alone, it does display the link, but if Mail
window is open on top of it, Browser remains behind Mail window. If another
program (WordPerfect) is on top of Mail, on top of Browser and I click an Active
Desktop link, Mail opens on top of WordPerfect on top of Browser.
Summary: external link shows mail instead of browser → external link shows mail instead of browser

Comment 2

14 years ago
I've seen this behavior on a friends computer, but couldn't reproduce it on mine.
Product: Browser → Seamonkey

Updated

12 years ago
Whiteboard: DUPME

Comment 3

11 years ago
WFM 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1 XpcomViewer/0.8.9
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.