XPInstall needs ability to detect userAgent

VERIFIED DUPLICATE of bug 51209

Status

Core Graveyard
Installer: XPInstall Engine
VERIFIED DUPLICATE of bug 51209
15 years ago
2 years ago

People

(Reporter: Kevin A. Burton, Assigned: Sean Su)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

We need the ability to detect the user agent for XPIs.

Specifically since the profile chrome addition there is a need to detect if we
are on a >= 1.3.1 build of Mozilla and then install to the profile dir or else
install into the system chrome directory.

On UNIX machines this is more pronounced since rpm/deb packages do NOT give
users the ability to install chrome into the system and XPIs that are installed
will always fail.

The problem is that there is no way to detect the userAgent so I can install
into profile chrome.

There is a variable Install.platform but this is just the OS.  What is needed is
Install.userAgent which is built at compile time.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Could also be a dupe of 162801. It appears to be a dupe of 51209, but is not
marked as such.


*** This bug has been marked as a duplicate of 51209 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: XPInstall needs ability to detect userAgent → XPInstall needs ability to detect userAgent

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.