adoraentertainment.com - serving HTML as text/plain

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: MZilla, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

I believe that Mozilla should identify this kind of page, even though it
appears that the content type is not correctly sent.

However, Internet Explorer is able to view this page correctly since it
sees the page as an HTML document and displays it as such.


Reproducible: Always

Steps to Reproduce:
1. Go to http://motu.adoraentertainment.com/cgi-bin/weblibs.pl
2. The page will load as a text page.
3.



Expected Results:  
I feel that it should have seen the HTML markup language and interpreted it
as a standard web page.

Comment 1

16 years ago
It's loading as a text page because the server says that's what it is:

HTTP/1.x 200 OK
Date: Tue, 01 Jul 2003 09:05:15 GMT
Server: Apache/1.3.27 (Unix) Sun-ONE-ASP/4.0.0 Resin/2.1.9 mod_log_bytes/1.2
mod_bwlimited/1.0 PHP/4.3.2 FrontPage/5.0.2.2510 mod_ssl/2.8.14 OpenSSL/0.9.6b
What: text/html
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/plain

So Mozilla does what the server says.  This is not a Mozilla bug.  It is:

1) A server misconfiguration
2) An IE bug that IE will render it

->TE
Assignee: general → english-us
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Component: Browser-General → English US
Ever confirmed: true
Priority: -- → P3
Product: Browser → Tech Evangelism
QA Contact: general → english-us
Summary: Content-Type Auto-Detect Pages → adoraentertainment.com - serving HTML as text/plain
Version: Trunk → unspecified

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.