Notification sound does not work

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Nigel Jewell, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

The bug 177280 and its duplicate 211149 indicate that bug 177280 has been fixed.
 However, still doesn't work for me.

No custom sound or default sound.

Using Redhat 9.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
The duplicate is bug 211149.

Comment 2

15 years ago
Was using self-extracting (not RPM) Mozilla 1.3 on RedHat Linux 8 (2.2.18) and
there was no notification sound. Downloaded 1.4 and the custom wav works, but
plays at the wrong Khz (way too fast). Happens with all tested wav files.

Comment 3

15 years ago
The speed issue is caused by a simple miscalculation in

widgets/gtk/nsSound.cpp line 184

instead of 
     rate = samples_per_sec * channels * (bits_per_sample / 8);
it should be
    rate = samples_per_sec *  (bits_per_sample / (8 * channels));

That fixed it for me with all available wav files.
(Reporter)

Comment 4

15 years ago
This bug is probably related to bug 211248.

Comment 5

15 years ago
Sorry, way too complicated!

As of using esound 0.2.29, it is best to use

several gtk-based files nsSound.cpp contain

    rate = samples_per_sec * channels * (bits_per_sample / 8);
change to
    rate = samples_per_sec;

not more! Now it plays 8 and 16 bit 
with 1 and 2 channels correctly

Tested with 1.4 final sources on 2.4.21 (Gentoo)

Comment 6

15 years ago
@Christian Bucher:
Is the rate miscalculation problem still there in current nightly builds? If
yes, could you please file a separate bug for it - it doesn't really belong in
this bug, since Nigel has originally reportet sounds not working at all. Let's
not mix different problems in the same bug.

@reporter:
Do you still see the problem? Do you have artsd or esd or any other application
or daemon running that might be blocking the sound device? To get sounds working
(Linux, KDE) I have to use 'artsdsp ./mozilla' to start Mozilla, otherwise artsd
will block the sound device, and mozilla natively doesn't know about arts.

To test, just kill anything that might be accessing the sound device and try again.

Comment 7

14 years ago
No reaction from the original poster in more than half a year - marking 
WORKSFORME

Please reopen if you can still reproduce the problem *with a current build*.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.