Java plug-in (JRE 1.4.2) doesn't work on Windows XP

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
--
major
RESOLVED INVALID
15 years ago
8 years ago

People

(Reporter: Oliwer, Assigned: Joshua Xia)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030612

All is in the summary...

Reproducible: Always

Steps to Reproduce:
1.Install the new JRE
2.Reboot your machine
3.Be sure that all necessary files are in the plug-in directory
4.See a web page containing a java applet

Actual Results:  
Mozilla wants me to get the plug-in from netscape.com

Expected Results:  
Mozilla should load the applet

I haven't forgoten the 'NPOJI610.dll'. It's really a bug.

Comment 1

15 years ago
-> OJI
Assignee: idk → joshua.xia
Component: Java-Implemented Plugins → OJI
QA Contact: avm → dsirnapalli

Comment 2

15 years ago
same problem under linux!!

Comment 3

15 years ago
Same problem in Win2000

Comment 4

15 years ago
how about at least listing what you have in about:plugins?
doesn't block development.

Is Windows:Start\Systemcontrol\Java Plug-in\Browser\[]Mozilla 1.1 or higher 

enabled ?
It will not work without this checkbox and the JRE needs Registry keys from the
installer (.zip doesn't work) to find Mozilla.
Severity: blocker → major
(Reporter)

Comment 6

15 years ago
My 'about:plug-ins' page is here > http://oliwer.free.fr/plugins.html
Severity: major → blocker
Severity: blocker → major

Comment 7

15 years ago
I am seeing the same problem under linux. From the command line here is the
error that it spits out.
The first one is using my installed jre and the second is with the jre
downloaded by the browser.

about:plugins - lists all my other plugins except java.
****************
LoadPlugin: failed to initialize shared library
/usr/local/bin/j2sdk1.4.1_03/jre/plugin/i386/ns610/libjavaplugin_oji.so
[/usr/local/bin/j2sdk1.4.1_03/jre/plugin/i386/ns610/libjavaplugin_oji.so:
undefined symbol: GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]

************
LoadPlugin: failed to initialize shared library
/usr/local/share/mozilla/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so
[/usr/local/share/mozilla/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so:
undefined symbol: __vt_17nsGetServiceByCID]
disterics@hotmail.com: You don't see the same error.
Your problem is a "user doesn't read the release notes" bug

Comment 9

15 years ago
disterics, check release notes and use ns610-gcc32

Comment 10

15 years ago
on the about:plugins page i cant see anything about java after installation of
the xpi packet.
is this a bug or..?

Comment 11

15 years ago
the linux version crashes also with jre 1.4.2... so there seem to be the same bug
(Assignee)

Comment 12

15 years ago
on win2k, You should also install mozilla by using install wizard because it
will write register items. JRE search those items to support browser.

if you install jre1.4.2 on win2k, please enable java plugin for mozilla >=1.1
(on Java Control Panel)

Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
*** Bug 211229 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
Joshua, can you mention what's needed exactly, the following reg key didn't work
(and yes I enabled Mozilla 1.1 in the Java control panel, which gave me an
error, telling me it couldn't be done):
http://plugindoc.mozdev.org/resources/firebird.reg
*** Bug 211616 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
Does Resolution INVALID mean that it becomes fixed, if not why not?
*** Bug 212517 has been marked as a duplicate of this bug. ***
*** Bug 218121 has been marked as a duplicate of this bug. ***
*** Bug 218084 has been marked as a duplicate of this bug. ***

Comment 20

15 years ago
For those that find this bug, and want to fix this error (because Mozilla
refuses to):

The JRE installation is looking for a registry key that Mozilla no longer
creates. If you manually create it, you can get Java working in Mozilla. The reg
keys needed are:

----------
[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org]

[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla]
"CurrentVersion"="1.0"

[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla\1.0]

[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla\1.0\Main]
"Install Directory"="C:\\Program Files\\Mozilla\\bin\\"
----------

You have to edit the "Install Directory" to your installation path. Now run the
Java Control Panel applet and check off Mozilla in the browsers tab.

Comment 21

15 years ago
Dumb question:
How does one access the Mozilla Java Control Panel applet? I know where the Java
console is. Help has no help on Java either.

This also seems like a valid bug to me. Why isn't the installer creating the
correct keys? Or why isn't Sun changing their plugin?

Comment 22

15 years ago
It's actually in the Windows Control Panel as "Java Plug-in"

Comment 23

15 years ago
I changed the registry settings, but used "c:\\Program files\\Mozilla\\" for the
location (there is no bin directory in Windows), and the Java control panel says
Mozilla is not properly installed, so it cannot enable Java for Mozilla.

Comment 24

15 years ago
It has to be the path to the Mozilla.exe file, and it has to include a trailing
slash.

Comment 25

15 years ago
check off Mozilla (in java panel) won't work with Firebird (with no previous
Mozilla install), however, the registry hack enables Java working in Firebird:
http://plugindoc.mozdev.org/phoenix.html
(and I even tried to create a dummy Mozilla.exe file)

Comment 26

15 years ago
I installed today's Mozilla build, and it removed those registry changes!
But after putting them in again, with the trailing \,the Java control panel
still says Mozilla is not installed properly.

Comment 27

15 years ago
With help from Jerry Baker, I got the java control panel applet to let me
nominate Mozilla for use by the 1.4.2 plugin. His post was slightly wrong.
Apparently, the problem is that Mozilla now adds an (En) after the 1.5b in the
registry tree, and you have to duplicate that branch with 1.5b rather than 1.5b
(En). (His post said to use 1.0).
However, my applet load in
http://bugzilla.mozilla.org/show_bug.cgi?id=218121
still fails, so I am not sure this is truly a duplicate.
*** Bug 224395 has been marked as a duplicate of this bug. ***

Comment 29

15 years ago
*** Bug 224636 has been marked as a duplicate of this bug. ***

Comment 30

14 years ago
*** Bug 216127 has been marked as a duplicate of this bug. ***

Comment 31

14 years ago
someone mind to clear up this nonsense and reopen this issue ? I like to.
Nothing is solved yet - and the sun-JRE works fine with IE, but not with Mozilla.

Martin
The sun JRE works fine with Mozilla on win2k

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.