[DOGFOOD] nsString crash when trying to view source

VERIFIED DUPLICATE of bug 20691

Status

()

Core
XPCOM
P3
normal
VERIFIED DUPLICATE of bug 20691
19 years ago
19 years ago

People

(Reporter: Scott MacGregor, Assigned: rickg)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
This symptom was initially used to re-open Bug #20700. I decided to open another
bug to track this.

Rick, on linux, if I bring up mozilla.org and then try to view source I crash in
nsStr::Truncate.

The code that causes the nsString to be called is in nsWebshell and it looks
like the following:

mURL = urlSpec;

mURL is an nsCString. urlSpec is an nsXPIDLCString.

urlSpec = "chrome://related/content/related-panel.xul"
the stack trace looks like:
nsString::Assign ("chrome://...", -1)
nsStr::Truncate ( , offfset = 0)
AddNullTerminator
and we crash on the call to AddNullTerminator

Marking this as dogfood since the bug it came from was a PDT / dogfood bug.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 1

19 years ago
Sorry Rick, I see you already have a bug with this same stack trace and it now
belongs to rick potts. I'll mark this as a duplicate.

*** This bug has been marked as a duplicate of 20691 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
Verified as dupe of 20691
 View source just opens toolbar-less window with the HTML rendering
You need to log in before you can comment on or make changes to this bug.