Closed Bug 211255 Opened 18 years ago Closed 18 years ago

Multiple tabs with forms causes unacceptable focus change

Categories

(Firefox :: General, defect)

x86
Windows 98
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 124750

People

(Reporter: cjmarks, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

When a new tab finishes loading in the background, and that tab includes a form
with a set focus, the focus goes to the tab in the background.  This means if
you're entering information in the open tab, and the new tab finishes loading in
the background, anything you continue to type will appear in the tab you can't see.

Reproducible: Always

Steps to Reproduce:
1. Go to any page that uses forms and sets focus on load
2. Open the same page in a new tab
3. While the new tab is loading enter form data in the new tab
Actual Results:  
When the new tab finishes opening my cursor will leave the open tab and I will
be typing in the tab I can't see.  When I move that tab to the foreground I'll
find the information I typed there.

Expected Results:  
If a tab is loading in the background, don't move the focus to it.  Focus should
never be set to a page you're not actively viewing.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
verified DUPLICATE 2003-ß9-03
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.