option to specify imap trash ANYWHERE

RESOLVED DUPLICATE of bug 182274

Status

MailNews Core
Networking: IMAP
--
enhancement
RESOLVED DUPLICATE of bug 182274
15 years ago
9 years ago

People

(Reporter: Ari Steinberg, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Opera/7.11 (Linux 2.4.21 i686; U)  [en]
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030618 Debian/1.3.1-3

Hi, I'm kind of new here so please be nice :).  I am aware of bugs 24064, 153716, 182274, and the many 
others like them.  However, they have all been fixed with a focus on allowing the user to change the 
name of the folder on the server.  You'll notice, though, that in each of these bugs, people have also 
requested the ability to move the trash to any other folder on the system; specifically, the local folders 
(or, I suppose, another IMAP server), and each time this part of the request seems to have been ignored. 
 This is useful for 4 reasons that I can think of:
1. Nice to keep an archive of your e-mails from all accounts in one central place instead of scattered 
across multiple accounts.
2. IMAP servers often have a limited amount of disk space, so archiving all your mail on the server is often 
not feasible.
3. UI consistency - in bug 182274, it seems they are planning to make the option a text field where you 
can type in the name of the folder to use as trash.  It seems that it would be more intuitive if this 
preference instead mirrored the format of your sent/drafts/templates folder options in the "copies and 
folders" panel.
4. Give local folders more of a purpose in life.  They are pretty much just wasting space for me at the 
moment, but I could definitely see the use for using them to archive trash from all my different accounts.

It seems that since work is already being put into allowing a configurable trash, we should go all the way 
and actually make it configurable and not put some artificial restriction of "configurable but only if you 
keep the folder on the server".

From a personal perspective, this is the one feature that keeps me coming back to KMail...I really want to 
make the switch to Mozilla for e-mail but would really appreciate this feature before doing that.  I suspect 
I might not be the only one.

Reproducible: Always

Steps to Reproduce:
1. Delete a message on an IMAP server.

Actual Results:  
It automatically goes to the trash folder on the IMAP server.


Expected Results:  
It should go to any folder you choose, in particular giving you the option to put it on the local server or 
another IMAP server.

Comment 1

15 years ago
I second everything said by poster of bug.  I Already have a trash folder that I
want to use.  It is called Deleted Items on my imap server.  I want to be able
to select it in exactly the same way that I was able to select sent/inbox/etc. 
I can't really fathom why the ui/options are different for these folder types.
(Assignee)

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 24064 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

15 years ago
sorry, re-opening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

14 years ago
*** Bug 215585 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
I found the real bug. It's bug 182274: Need UI for server trash folder name.

*** This bug has been marked as a duplicate of 182274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

14 years ago
Steffen, did you read the bug description?  I specifically explained how this
differs from bug 182274 - there are 2 key differences: 
1) it should be possible to specify the trash folder on _any_ server or even
locally, just as you can for your sent and drafts folder.
2) the ui should be identical to the sent and drafts folder choosers.

Can someone please re-open this?  Thanks.
(Reporter)

Comment 7

14 years ago
Steffen, did you read the bug description?  I specifically explained how this
differs from bug 182274 - there are 2 key differences: 
1) it should be possible to specify the trash folder on _any_ server or even
locally, just as you can for your sent and drafts folder.
2) the ui should be identical to the sent and drafts folder choosers.

Can someone please re-open this?  Thanks.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 8

14 years ago
Woops, sorry about the duplicate post (err, guess i'm now "triplicating" it). 
didn't realize I could re-open it myself.

Comment 9

14 years ago
Ari, I really like your idea. It should be possible to specify a local folder as
trash. I'm not saying that your proposal is bad, or that you propose exactly the
same as bug 182274.
But it's the same UI for the same functionality: Specify the trash folder as a
folder which has to be on the server (that bug), or as any folder (this bug). We
can't implement both ways at the same time. We need a single bug to discuss this
therefore. This is bug 182274, because it's older and contains a lot of
discussion on how to implement it.

Please post your suggestion in bug 182274!

-> Marking as duplicate again.

*** This bug has been marked as a duplicate of 182274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.