All users were logged out of Bugzilla on October 13th, 2018

Cookie Manager: chrome: URL does not work w/o parameters

RESOLVED WONTFIX

Status

()

P5
enhancement
RESOLVED WONTFIX
16 years ago
15 years ago

People

(Reporter: bluejamc, Assigned: mconnor)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030701 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030701 Mozilla Firebird/0.6

When viewing the Cookie Manager by going through the preferences, the sites and associated cookies are (correctly) listed.  However, when calling the UI directly by going to chrome://communicator/content/wallet/CookieViewer.xul , the list which should have the sites and the associated cookies is empty.  I'm not sure if this is by design, but it seems that if the UI is supposed to be accessible, the actual cookies should be as well.

Reproducible: Always

Steps to Reproduce:
1.  Go to the cookie manager like you normall would.
2.  Witness all the existing cookies.
3.  In the address bar (or in a bookmark, or whatever) use the URL chrome://communicator/content/wallet/CookieViewer.xul

Actual Results:  
The Cookie Manager window opens like expected, but none of the sites that were listed when going to the cookie manager normally are listed.

Expected Results:  
It should have listed the sites, along with the associated cookies, as if the window were opened via the normal preferences.

Exists in both Mozilla 1.4 and Firebird version listed above.  Happens in default theme for both of them.
And why should that work? There is a button in prefs for opening the manager, no
need for hackish other ways.
hint: you need to pass some arguments to the .js script.
(Reporter)

Comment 2

16 years ago
Why should it work?  Why shouldn't it?  What's the good of having the UI accessible if it's empty when you get to it?

As for the button in prefs, yes, there is a button in prefs...and it only takes five clicks to get there in Firebird.  It might as well be inaccessible, as far as I'm concerned.

As for your hint, I'm assuming you mean

javascript:window.open("chrome://communicator/content/wallet/CookieViewer.xul","_blank","chrome,resizable=yes");

which still brings up a window with no entries.

Unless you have a better suggestion, in which case how about sharing instead of hinting?
No, I mean what
http://lxr.mozilla.org/seamonkey/source/extensions/cookie/resources/content/cookieOverlay.js#29
does.

 29 function viewCookies() {
 30  
window.openDialog("chrome://communicator/content/wallet/CookieViewer.xul","_blank",
 31                     "chrome,resizable=yes", "cookieManager");
 32 }  

I don't think that all the internal mozilla windows need to be accesible by just
opening an url in the browser. It is nice if it doesn,t but if an extra param or
something, let it be.

Comment 4

16 years ago
confirming and futuring enhancement request.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → Future

Comment 5

16 years ago
If cookie manager is hard to get to in Firebird, that should be a separate UI bug.

I think this bug is invalid because when you called the chrome URL, you got what
you asked for.
Summary: When calling the chrome URL for cookie manager, site entries and associated entries aren't listed. → Cookie Mnagaer: chrome: URL does not work w/o parameters
(Assignee)

Comment 6

15 years ago
Between the button in prefs and the options in Tools->Cookie Manager, this is
easily accessible as-is.  I don't think that the (questionable) benefits of
being able to open the chrome URL directly is worth the increased code
maintenance required.  This would require splitting the image manager into its
own file and modifying all of the callers throughout the UI, along with
maintaining both files and making changes to both files if/when enhancements land.

Also, since this is falling into my lap as the guy doing cookies UI, I don't
intend to split these files up unless someone gives me an extremely good reason
to do so.  Taking to evaluate further, as this might happen as a byproduct of
future changes to cookiemgr, but on its own there is no compelling reason to
change this.
Assignee: darin → mconnor
Summary: Cookie Mnagaer: chrome: URL does not work w/o parameters → Cookie Manager: chrome: URL does not work w/o parameters
(Assignee)

Comment 7

15 years ago
if this happens, it'll be incidental to other work.
Priority: -- → P5
(Assignee)

Comment 8

15 years ago
marking WONTFIX.  The benefit of this is trivial compared to the detrimental
effect on code maintenance that splitting the two managers would create.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.