support new gpl file format

RESOLVED INVALID

Status

()

Core
ImageLib
--
enhancement
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: Carol Spears, Assigned: Carol Spears)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

I think that I have found a file format that has potential, the gpl and everyone
I know seems to like.

http://www.cs.waikato.ac.nz/~singlis/

Articulate (still) about free software as well?

Any complaints? please send them to maintainer@netscape.com.

Reproducible: Always

Steps to Reproduce:
1.search for maintainer
2.file bug report
3.review promises
4.goto 1

Actual Results:  
nothing in my mailbox today

Expected Results:  
small, nice, flexible graphics file formats where the maintainer is clear with
his intentions and they match those of the gpl.  ... musicians, ...font artists,
...also css artists, maybe.  Free and Interested High Class Developers.

crashes on gpl, amazing how gpl clears the **** away.

and yes, unfortunately, a *normal* bug.  It should be fixed.
GPL is not enough for Mozilla because Mozilla is licensed under a MPL/LGPL/GPL
tri-license.

And this is not Accessibility API -> Imagelib (for "wontfix" because it's only
under GPL ?)
Assignee: aaronl → jdunn
Severity: normal → enhancement
Component: Accessibility APIs → ImageLib
QA Contact: dsirnapalli → tpreston
Unfortunately, the GPL is a very restrictive license.  In particular, Mozilla
cannot include any code that is solely licensed under the GPL, because some uses
of Mozilla code would violate the license.

So, regretfully, we cannot add support for this file format at this time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Assignee)

Comment 3

15 years ago
Okay, I am so confused.  Where is that browser that the good old Netscape people
released the source code for.  I was telling people it was Mozilla.  I get many
things wrong.  Please, instead of just correcting me, can you tell me what
happened to that cool browser source code that was released to the people so
they would always have a free and accessible browser.

I have been giving lip-service to a coorporate browser.  Someone owes me some
money.  Where do I send the bill?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Comment 4

15 years ago
From - Wed Jul 02 06:25:09 2003
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00800000
Message-ID: <3F02B304.4040503@gimp.org>
Date: Wed, 02 Jul 2003 06:25:08 -0400
From: Carol Spears <carol@gimp.org>
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623 Deb
ian/1.0.0-0.woody.1
X-Accept-Language: en
MIME-Version: 1.0
To:  jdunn@netscape.com,  tpreston@netscape.com,  rms@gnu.org
Subject: hello from michigan
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

Hi there!

I guess I have been actively selling a coorporate backed browser.

I am in need of my compensation now.

Who do I mail the bill to?  I only advocate free software.  Apparently 
this is not the free software project I thought it was.  

How much does your sales team get per hour?  I have a huge bill that 
needs to be paid for past services rendered.

Carol Spears
I'm not quite sure what you are talking about. Yes, this is the browser that
netscape released the source code for, and it is a free browser.

I have some trouble understanding your last two comments...

fact is, (most of) the mozilla code is tri-licensed under an MPL/GPL/LGPL
license (i.e. you can choose one), and GPL is incompatible with the MPL, which
makes it impossible to include GPL code in Mozilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
(Assignee)

Comment 6

15 years ago
I found it very interesting how gimp developers handled the gif issue.  Since
gif format was not free, you needed to make an effort to download and install
the whole chain of software to get to it.  That way, you were assured to know
that the software was not free.

How about using this model, only invert it.  Where the browser comes with the
free software, but a good developer who knows he cannot work with free software
can remove his access to the free stuff.  Knowingly (just like to get the non
free gif format) step through the process to remove the algorithm from their work.

This would help the users, like me.  This way, we would know what is free and
what we pay for.

But the free stuff should come installed.  Developers, not users, should
uninstall free stuff if they can't handle it. 
(Assignee)

Comment 7

15 years ago
oops!

someone keeps closing this.

i am trying to pay my cable bill.

have mercy!!
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Comment 8

15 years ago
The more i think about this the better.

Take for instance the ogg file format.  If mozilla came automatically working to
handle oggs, which are free and probably **** because of this, then the user
would automatically go through the steps of getting the mp3 players.  Their ear
would make them change for the superior sound format, as opposed to the ****
free format of audio file.

This is how gif worked for me.  After going through the hoops to get the
libraries installed, I could see what a wonderful thing corporate protection of
a file format worked when I compared the gif format to the png format.  gif is
far superior with its handling of semi alpha and all that.

After taking all the steps to install the ability, I was fairly well convinced
that UNISYS and copyright protection really improved things on my computer.  

Anyone care to sample the difference between an ogg and an mp3?  gif and png
might be enough to compare with.

Copyright is cool.  If you are protecting it, and cannot allow it to be compared
and chosen with free stuff, this copyright was not written to protect your stuff
being delivered, it was to protect your stuff from being delivered for free.

You are delivering non-free software and hiding the free stuff.  I think you
hurt the people who need to make money from their software development this way.
 The free stuff is not free or accessible and the non free stuff apparently
comes installed.

Doesn't make sense.
> Copyright is cool.

Yep.  Like the GPL, which is a copyright.  Again, the problem here is that the
GPL is a strong copyright that places strong limitations on how the software can
be used.  This is by-design, since Richard Stallman feels that all software
should be used only in certain ways.

For an example of a truly free license, I recommend looking at the Artistic
license or at the BSD license.

The Mozilla license falls somewhere in between, but the point is that it allows
people to use Mozilla code in ways in which GPL code cannot be used.  Yes, this
means that peopler can create closed-source applications using Mozilla code --
the same is true of Perl, for example.  Is Perl a "coorporate [sic]" language?

Please try to not spout incorrect information and insult people, ok?

In any case, this is still wontfix.  The file format you are pointing to has no
clear specification short of the source, and anyone who reads the source would
be unable to implement it in Mozilla.  We could spend the enormous effort to
clean-room reverse-engineer the format and implement it, and we will do that if
the format takes off.... at the moment, that large time investment does not seem
worthwhile.

Please do not reopen this bug unless you can provide some technical information
that would affect the technical decision.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 10

15 years ago
Well, sorry.  Please borrow some of the patience while I wait for a maintainer
to respond to this bug report:
http://bugzilla.mozilla.org/show_bug.cgi?id=18574

Saying "no" is so easy.  Perhaps you could offer a different suggestion.  All
the doors seemed to be slammed closed.

Maybe this is the place to educate.

I think my idea about fully loading a free browser with freesoftware is such a
great idea; I find the "No!" to be more rude than the values attached to the
gpl.  The mp3 people are proud enough of their format to separate it and start
to charge for it along the feeding chain.  Vorbis guys seemed to be glad for the
stepped up competition http://www.xiph.org/ogg/vorbis/openletter.html

and truly, I do not know how this file format is licensed.

Can you suggest an animation format that TheGIMP can use and be certain it will
be supported by one freaking non-corporate browser?

They are just sitting around looking for a file format that will work, you just
say no, and the other netscape.com people I guess are not answering.

Educate me on which file format to use to meet my needs and stop closing this
bug, please.

Do i need to start a new report?  "Need Free and Not Sucky Animation File
Format", I can do this.  I will learn how this bugzilla can actually fix
problems at the same time.

Where are the mng maintainers?  Did I read that they have a netscape.com addy
also, can you ask them to respond to the other bug reports that we wait for?

I need to have a bug report active until I find a file format.  We can wait
until I am fully educated in the toggle button, or you can suggest a file format
that will work.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
-> carol@gimp.org  

to find get a compatible license (GPL is not compatible with Mozilla),
documentation and also to implement it.

Assignee: jdunn → carol
QA Contact: tpreston → carol

Comment 12

15 years ago
I am just going to chime in for the heck of it (because
I have a .ns.com email address - lot of good it does me).

Boris knows this stuff way better than I do and I am
in complete agreement with him.  And while I understand 
your pain, there are a bunch of reasons why not to implement
this. (heck we just tore MNG support out because it was 
the *right* thing to do).  

One suggestion I will make in moving forward is to specify
(in the bug) the problem(s) you are trying to address.
If it is just to support http://www.cs.waikato.ac.nz/~singlis/
in mozilla fine, say it... but a more constructive approach
might be mention the specific problem (need a way to support
various media format & list the formats) and then *suggest*
a possible solution.  since there are *lots* of very smart
people working on mozilla (like boris) who might know of
ways to help.  Heck who knows maybe dialog can be opened
with Stuart, get a *licensing* setup that is ok with him
and with mozilla and provide an XPI installable component...

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.