If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Element.replaceChild is writable

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: bc, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
You can over-write the replaceChild method of an element.
(Reporter)

Comment 1

14 years ago
Created attachment 126877 [details]
testcase

this happens on 1.4 and trunk
Hmm.. why is this a bug? There's no reason that you should not be able to
override functions on objects if you want to, is there?
(Reporter)

Comment 3

14 years ago
maybe it's not a bug. I mistakenly thought this was a unique case.
Nope, not a bug. You can do the same with any DOM methods...
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: desale → general
You need to log in before you can comment on or make changes to this bug.