Mozilla can't start RealOne plugin

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: mcicogni, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Mozilla always displays a "plugin missing" box.
I obviously do have RealOne installed and working, and I did check I had the
plugin DLL & XPT files in the correct places.
About:plugins does show Real and it does say it's activated.

Reproducible: Always

Steps to Reproduce:
1. Install RealOne (it does detect Mozilla automatically and puts its files in
the right places).
2. Go to mentioned URL.


Actual Results:  
Witnessed appearance of "plugin missing" box.

Expected Results:  
Display RealOne interface within the page and play a live radio broadcast.

I will mention that I have done a bit of research myself. AFAIK, this behavior
arises from a MIME type misunderstanding, since the page appears to require
"audio/x-pn-realaudio" but the plugin only advertises
"audio/x-pn-realaudio-plugin". I edited the DLL resources adding
"audio/x-pn-realaudio" to the MIME types it says it supports (had to do a fair
bit of digging into the plugin writing docs to learn how to do this), restarted
Mozilla and the RealPlayer interface appeared.

Still, it doesn't run, and after a bit of fiddling I found out that it's because
RealPlayer can't find the bits it should play.
In fact, I tried saving a local version of the page, putting an absolute URL
within the "SRC" parameter, and got it working.
Please mind that for some reason I had to put the absolute path in the PARAM
tag, and putting it in the SRC parameter of the EMBED tag did not work.

So, I'd argue that the plugin does get loaded but Mozilla does not tell it the
correct place to find the audio stream. I will say that this might but a side
effect of having edited the DLL resources, i.e. trying to make it work (maybe if
the plugin had been started with the correct MIME type it would have known it
was a plugin and got the right URL to load).

Comment 1

16 years ago
Source code makes me feels this bug could be applied into Tech Evangelism, Italian.

Look at this source code :

"<td align="center" valign="top"> <object id=RVOCX
classid="clsid:CFCDAA03-8BE4-11cf-B84B-0020AFBBCCFA" width=375 height=100
name="live">
              <param name="SRC" value="radio2.ram">
              <param name="CONSOLE" value="one">
              <param name="CONTROLS" value="All">

              <param name="BACKGROUNDCOLOR" value="white">
              <param name="CENTER" value="true">
              <param name="AUTOSTART" value="true">
              <embed width="375" height="100" src="radio2.ram" console="one"
backgroundcolor="white" center="true" autostart="true" name="live">
              </embed> 
              </object>"
(Reporter)

Comment 2

16 years ago
Hmmm, what should I do then?

Comment 3

16 years ago
Well, I'm moving this bug to tech evangelism / Italian, and see if someone there
can help a little more.
Assignee: peterlubczynski → italian
Component: Plug-ins → Italian
Product: Browser → Tech Evangelism
QA Contact: bmartin → italian
Version: Trunk → unspecified
Related to bug 276973?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

12 years ago
The new URL for the radio is http://www.radio.rai.it/player/player.cfm?Q_CANALE=1 and it works fine.
It's time to close the bug as fixed.
(Reporter)

Comment 6

12 years ago
I can confirm the Real Player plugin appears and works fine.
Possibly the RAI developers catched up with this last 4 years ;-)
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.