Core Graveyard
Java-Implemented Plugins
15 years ago
6 years ago


(Reporter: Marek Dabrowski, Assigned: Igor Kushnirskiy)


Firefox Tracking Flags

(Not tracked)




15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Mozilla 1.4 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
java plugin dont' work
1. plugin from blackdown j2sdk1.4.1
Eroor during start mozilla (mozilla started but without java plugin)
LoadPlugin: failed to initialize shared library /usr/local/j2sdk1.4.1/jre/plugin
[/usr/local/j2sdk1.4.1/jre/plugin/i386/mozilla/j                          undefined symbol:

2 plugin from sun j2sdk_nb
Error during start mozilla (mozilla didn't start)
INTERNAL ERROR on Browser End: No manager for initializing factory?

System error?:: Sukces

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
How did you install java plugin ? Symlinking it or copying it into plugins

I used Blackdown 1.4.1 before Sun 1.4.2 and both works.

Comment 2

15 years ago
I make symlinks from plugin directory to mozilla directory. In version 1.4-RC1
java plugin work fine. In version 1.4-RC3 java plugin stop working.

Comment 3

15 years ago
Plugin java for linux from netscape
didn't work too (but work in 1.4-RC1)

Comment 4

15 years ago
With mozilla 1.4rc3 and younger, YOU HAVE TO use JRE 1.4.2 / BlackDown JRE 1.4.1
gcc3.x version.

This is written in release notes, in "what's new" :

"The Linux binaries distributed by are now compiled with GCC 3.2. If
you're using these binaries then you will need the 3.2 version of the Java
Plugin from Sun J2SE v 1.4.2 (or the Blackdown JDK 1.4.1 compiled with GCC 3.2.)
The Sun Java Plugin is compatible with modern Linux versions like Red Hat 8 or
later and SuSE 8.1 or later (the plugin depends on a newer version of, installing the GCC supplements for Red Hat 7.3 -GCC 3.1 Compiler
Suite for Red Hat Linux 7.3 - may allow for some older Red Hat Linux to run the
plugin) Users of older Linux versions should either install the egcs 1.1.2 build
of Mozilla and the JRE 1.4.1 or wait for a Mozilla version compiled specifically
for their Linux distribution."

So as it seems you're not using a gcc 3.x based JRE, your bug is invalid.
Invalid.  The plugin you are using will not work, as listed in the release notes.
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 6

15 years ago
But forget your internet banking account, it will not work with 1.4.2 plugin.
See bug #210925.
Component: Java-Implemented Plugins → Java-Implemented Plugins
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.