embedding component gives error when attempting to launch

RESOLVED INCOMPLETE

Status

--
critical
RESOLVED INCOMPLETE
15 years ago
2 years ago

People

(Reporter: kysmith, Unassigned)

Tracking

({smoketest})

Trunk
x86
Windows 2000
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030702 Netscape/7.1+ (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030702 Netscape/7.1+ (ax)

I ran mfcembed-win32-installer.exe and gre-win32-installer.exe top install the
embedding browser. After installation I proceed to launch browser by running
C:\Program Files\mozilla.org\MfcEmbed\mfcembed.exe. Instead of a embedding
browser coming up I get a win32 error popup titles "mfcembed.exe - Unable to
locate DLL". Body of the popup contains
"The dynamic link library xpcom.ddl could not be found in the specified path
C:\Program
Files\mozilla.org\MfcEmbed;.;C:\WINNT\System32;C:\WINNT\system;C:\WINNT;C:\WINNT\System32\Wbem.

Reproducible: Always

Steps to Reproduce:
1. run mfcembed-win32-installer.exe
2. run gre-win32-installer.exe
3. run C:\Program Files\mozilla.org\MfcEmbed\mfcembed.exe
4. observe popup error 

Actual Results:  
got error popup

Expected Results:  
launched the embedding browser

Updated

15 years ago
Keywords: smoketest
Summary: embedding component gives error when attempting to launch → embedding component gives error when attempting to launch

Comment 1

15 years ago
I don't see any suspicious checkin that could have triggered this. Adding some
folks to cc list. 
When was this last known to work?  (Is this something that's tested every day?)

Comment 3

15 years ago
Tracy tests embeddinf on M, W and F.
The last test should be this monday.
(Reporter)

Comment 4

15 years ago
This is tested M-W-F. According to Tracy's report it worked on June 30th OK. 

NOTE: This was my first time attempting to install the win32 embedding browser.
I was following the steps I had written down from talking with Tracy but perhaps
I was doing something wrong. Can someone verify the installation steps I was
following please? 

Comment 5

15 years ago
I tried the similar steps using 6-30 build and ran into the same issue. I think
there is some additional steps to run embedding builds.

Comment 6

15 years ago
aren't you suppose to run the application with runapp.bat?  I guess even if you
did, that bat file still references the 1.3b milestone GRE.  

I really don't think you need to run both installers.

I really have never used the MFCEmbed, but I know that the way it uses the GRE
is not correct.  See 205084.

Comment 7

15 years ago
because we don't know if the steps to reproduce are valid and these steps do
produce problems on passed builds, there is no reason to keep the tree closed.

this is no longer a blocker
Severity: blocker → critical

Comment 8

15 years ago
kysmith, any luck figuring out the propery way to run this test case?
(Reporter)

Comment 9

15 years ago
DOn't yet know about running the test case, I can update this on wednesday once
Tracy gets back from vacation. 
Sean made a change to the GRE installer that aloows only installation to the
default location.  mfcembed needs the GRE installed in the same location it is
installed. The only way I've found to run this is to copy the contents of the
GRE installation over to the location of the mfcembed location.
(Reporter)

Comment 11

15 years ago
More from Tracy on a different way to do this...
- run the gre installer (gre-win32-installer.exe) first, letting it go to the
default location, note this info (you can browse to a new location for
installation but that setting will be ignored)
- run the mfc installer (mfcembed-win32-installer.exe) next, select the location
where gre was installed to for this mfc installation
- run the exe mfcembed.exe from this location and away you go

NOTE: the batch file runapp.bat doesn't work. 

Comment 12

11 years ago
mass reassigning to nobody.
Assignee: dougt → nobody
QA Contact: ashshbhatt → gre

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.