Crashes on install unless installed w/o plugins or xpi's

RESOLVED INVALID

Status

()

Core
XPCOM
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Robert Schwartz, Assigned: dougt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

See 211363. 

I uninstalled 1.3.1 and Java 1.4.1. 

I renamed the old mozilla directory to "Lizard" (it still had old plugins, icons
and spellcheck xpi). 

I backed-up my profile. 

I installed Java 1.4.2. Rebooted. Installed Moz 1.4 to a new directory. It worked. 

I copied old plugins and icons to the new directory. It still worked.

I downloaded new xpi for spellcheck.

Reproducible: Always

Steps to Reproduce:
1.uninstall 1.3.1
2.rename old directory
3.Install 1.4 to a new directory.

Actual Results:  
worked

Expected Results:  
should have worked in old directory after uninstall of 1.3.1. 

I have installed every version since 0.9.4, this is the first time that I had to
install to a new directory instead of a cleaned out old directory with my
plugins and icons. 

Please reword the New Issues note as follows:

http://www.mozilla.org/releases/mozilla1.4/README.html#new-issues

If you are experiencing crashes on startup in xpcom.dll it is very likely that
there is an incompatibility with your old plug-ins or xpi's. To work around this
problem, uninstall your previous version of Mozilla, and rename or completely
delete the Mozilla install directory before performing the new install. You will
not lose your profile data (such as bookmarks, preferences and cookies) but any
third party extensions and plugins may be lost, unless they are copied or
backed-up. After installation of Mozilla 1.4 you may copy your old plugins to
your new plugin directories. NOTE: do not use your old Java plug-ins unless you
previously installed Java 1.4.2, see above.


replaces #211363 
Almost identical to #211353 diff is that he was using XP. 
Also #205277 but that was in 1.4 beta
Bug 211458 has been marked as a duplicate of this bug.

http://www.mozilla.org/releases/mozilla1.4/README.html#new-issues

    * If you are experiencing crashes on startup in xpcom.dll it is very likely
that there is an incompatibility with some third-party extension. To work around
this problem, uninstall your previous version of Mozilla, and completely delete
the Mozilla install directory before performing the new install. You will not
lose your profile data (such as bookmarks, preferences and cookies) but any
third party extensions and plugins may be lost.

The following threads from mozilla news should be reviewed:

http://groups.google.com/groups?threadm=3F025523.7020102%40tired.of.hotmail.spam.com&prev=/groups%3Fhl%3Den%26lr%3Dlang_en%26ie%3DUTF-8%26safe%3Doff%26group%3Dnetscape.public.mozilla.browser

http://groups.google.com/groups?threadm=1gsEa.9843%248l.638006%40news2.telusplanet.net&prev=/groups%3Fhl%3Den%26lr%3Dlang_en%26ie%3DUTF-8%26safe%3Doff%26group%3Dnetscape.public.mozilla.crash-data

http://groups.google.com/groups?threadm=bd80i7%248nu1%40ripley.netscape.com&prev=/groups%3Fhl%3Den%26lr%3Dlang_en%26ie%3DUTF-8%26safe%3Doff%26group%3Dnetscape.public.mozilla.crash-data

http://groups.google.com/groups?threadm=69809db8.0306300031.6ddf51cf%40posting.google.com&prev=/groups%3Fhl%3Den%26lr%3Dlang_en%26ie%3DUTF-8%26safe%3Doff%26group%3Dnetscape.public.mozilla.crash-data

http://groups.google.com/groups?dq=&hl=en&lr=lang_en&ie=UTF-8&group=netscape.public.mozilla.crash-data&safe=off&selm=126ee2c2.0307010854.95f60f0%40posting.google.com

http://groups.google.com/groups?threadm=bdt56b%24voivv%243%40ID-106624.news.dfncis.de&prev=/groups%3Fhl%3Den%26lr%3Dlang_en%26ie%3DUTF-8%26safe%3Doff%26group%3Dnetscape.public.mozilla.qa.general
Do you installed in a directory with an old build (old build with installed
spellchecker in that directory) ?

That would make this bug invalid because it's the spellchecker addon and the
Mozilla uninstaller doesn't delete the spellchecker. Also note that Mozilla now
stores some Data in a different directory (GRE) if you use the installer.

A working plugin doesn't make a new build crashing and this would be a valid
plugin bug. (addon!=plugin)

bug 20577 is opened in the 1.4b timeframe but still valid (it's still open).
(Reporter)

Comment 2

15 years ago
Matti (Matthias "hating marquee" Versen) wrote:

>Do you installed in a directory with an old build (old build with installed
>spellchecker in that directory)?

Robert Schwartz replied:

AMD Duron 850 256 MB Win98SE. I have installed and used each Mozilla version
since 0.9.4. I was running 1.3.1.

On 7/1/03

I uninstalled 1.3.1. using the Windows Control Panel Add/Remove applet 
& cleaned out the old directory (as I had done with installations
of versions from 0.9.5 through 1.3.1), 
but I did not delete my old plugins, icons or spellchecker.

I installed 1.4. It would not start and gave me an XPCOM.DLL error.

I uninstalled 1.4 using the Windows Control Panel Add/Remove applet
rebooted, re-installed it in the old directory with the same result
and did it one more time -- no joy.

I uninstalled 1.4 and installed 1.3.1.

On 7/2/03

I researched the newsgroup archive on Google and re-read the New Issues Notes.

I uninstalled 1.3.1 and Java 1.4.1. using the Windows Control Panel Add/Remove
applet

I renamed the old mozilla directory to "Lizard" (it still had the old plugins,
icons and spellcheck xpi). 

I backed-up my profile. 

I installed Java 1.4.2. and Rebooted. 

I installed Moz 1.4 to a new directory. It worked. 

I copied NPJava11.dll, NPJava12.dll, NPJava13.dll, NPJava14.dll, NPJava32.dll, 
NPJPI142.dll, NPOJI610.dll from the Java 1.4.2 directory 
"C:\Program Files\Java\j2re1.4.2\bin" to the new plugin directory
"C:\Program Files\Mozilla\plugins"
I then copied the old plugins and icons to the new directory.

It still worked.

I downloaded a new xpi from mozdev.org for spellcheck.

It still worked.

Sigh!

Matti (Matthias "hating marquee" Versen) wrote:

>That would make this bug invalid because it's the spellchecker addon and the
>Mozilla uninstaller doesn't delete the spellchecker.


Robert Schwartz replied:

The bug is: "Crashes on install unless installed w/o plugins or xpi's"

I do not know whether the plugins, the icons or the spellchecker caused the crash.

I do know that the first 3 times I installed 1.4,
I installed it the same way that I installed
0.9.5,0.9.6,0.9.7,0.9.8,0.9.9,1.0,1.1,1.2.1, 
and 1.3.1 and I never had a problem with
any of those installations like this one.

This is a bug. It is not a big ugly wasp 
but it is an annoying housefly.

Matti (Matthias "hating marquee" Versen) wrote:

>A working plugin doesn't make a new build crashing and this would be a valid
>plugin bug. (addon!=plugin)

Robert Schwartz replied:

Again, I do not know whether the plugins, the icons or the spellchecker
or some combination of 2 or more or all 3 caused the crash.
I do know that the same installation procedure worked for previous versions.

Matti (Matthias "hating marquee" Versen) wrote:

>bug 20577 is opened in the 1.4b timeframe but still valid (it's still open).

Robert Schwartz replied:

Yeah but this one is fully described.

--------------------------------------

Final note: I revised my suggested wording of the New Issues Note

Please reword the New Issues note as follows:

http://www.mozilla.org/releases/mozilla1.4/README.html#new-issues

Windows users: If you upgrade from a previous version of Mozilla and 
Version 1.4 crashes on startup with an error message indicating a 
problem in xpcom.dll, it is most likely that the crash was caused by
an incompatibility between 1.4 and your old plug-ins or xpi's.

To avoid this problem or to work around it if it has occured,
uninstall your installed version of Mozilla using the Windows Add/Remove
facility or MozillaUninstall.exe.
Then rename or completely delete the directory the old Mozilla was installed in.
Finally, install version 1.4 in a new empty directory.

NOTE: You will not lose your mail, news or profile data 
(such as bookmarks, preferences and cookies) but plug-ins 
and xpi's may be lost, unless they are saved in a renamed 
directory or copied or backed-up to a new directory.

After installation of Mozilla 1.4 you may copy your old plugins
to your new plugin directories, but do not use your old Java plug-ins
unless you previously installed Java 1.4.2, see above.
>but I did not delete my old plugins, icons or spellchecker.
                                               ^^^^^^^^^^^^^

->invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

15 years ago
Rubish. its a bug
You need to log in before you can comment on or make changes to this bug.