In 1.5 nightlys can't open exe files without saving them

VERIFIED INVALID

Status

SeaMonkey
Download & File Handling
--
major
VERIFIED INVALID
15 years ago
13 years ago

People

(Reporter: gls, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030701
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030701

This is a breakage that was fixed in 1.4 but comes back in 1.5 nightlys:
In 1.4 builds you used to be now able to open EXE files without saving them like
in IE. But now it won't allow you to in 1.5. This is a major breakge that MUST
be fixed

Reproducible: Always

Steps to Reproduce:
1.Find and download a EXE file
2.Select open with
Actual Results:  
Note that if you type nothing in the box beside that the OK button is dimmed

Expected Results:  
It should show a box without a box beside open with and labeled Open, leaving
you with only "Save to Disk" or "Open" as choices
> In 1.4 builds you used to be now able to open EXE files without saving them like
> in IE.

Um... no.  You could launch files immediately after they finished downloading,
but you could never do the "like in IE" thing.

I don't have windows on hand to test, but I reviewed the patch that added the
"launch file" functionality, and it has not changed since (it's identical in 1.4
and trunk).

I'll let someone who actually has windows mark this invalid after testing...
(and setting OS to windows, since the launching thing was Windows-only).
OS: All → Windows 2000

Comment 2

15 years ago
I get the same results in both 1.4 and the latest nightlies, neither of which
had an Open choice like IE has.
(Reporter)

Comment 3

15 years ago
I can say that they have told a BIG lie!!

Reporter
This is not a bug, this is working as designed.

Reporter, if you can locate a build that allows this behaviour, go ahead and
reopen this bug with that build ID.  Otherwise this is not a bug as this is
working as designed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
windows 2000, using the 1.4 release from mozilla.org (installed with the full
installer):

Clicking the 1.4 Net Installer link
(http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.4/mozilla-win32-1.4-stub-installer.exe)
does not show an "Open" option. If "Open With" is selected and nothing is
entered in the text field, "Open" is greyed out. This behaves as expected.

Not being able to directly open .exe file is fully intentional.

I am not sure what the "big lie" should be.

marking verified.
Status: RESOLVED → VERIFIED
oh, one more thing - after the downloading is finished, I can click "Launch
File" to launch the executable. This is also as designed (also see the release
notes: ""Launch file" after downloading has been enabled for .exe files")
(Reporter)

Comment 7

15 years ago
And that's in the download manager (Still has to be saved though)
(Reporter)

Updated

15 years ago
OS: Windows 2000 → All
Yes, and in the progress dialog too. What's your point?

(also, this is windows-specific. on linux, downloaded files are not executable
directly.)
OS: All → Windows 2000
Hardware: All → PC
(Reporter)

Comment 9

15 years ago
But it still means you have to save it before opening
For the final time, that's the only way its ever worked or been meant to work. 
You download it, save it, and click Launch File.  There is no IE-style method of
"open from current location" and I don't know if there ever will be.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.