Shift tab inside bullet list doesn't un-ident bullet, but jumps to Subject box.

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: fabio.paoli, Assigned: neil)

Tracking

({fixed1.5, regression})

Trunk
x86
Windows XP
fixed1.5, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

When composing a mail, if you use a bullet list you can ident the bullet by
pressing TAB but when you press Shift TAB it doesn't un-ident the bullet, it
jumps to Subject box.

This was working fine inside Mozilla 1.3.

Reproducible: Always

Steps to Reproduce:
1.Compose a mail
2.Press the bullet list button, and type some characters.
3.Press tab, the bullet will ident, then press shift tab and it won't un-ident.

Actual Results:  
I get moved to the Subject box.

Expected Results:  
Un-idented the bullet.
(Assignee)

Comment 1

15 years ago
Looks like a regression from bug 54035.
Status: UNCONFIRMED → NEW
Depends on: 54035
Ever confirmed: true
Keywords: regression
(Assignee)

Comment 2

15 years ago
Created attachment 131133 [details] [diff] [review]
First go at a patch

Well MsgCompose has a funky tabbing order, so I can't let the esm do all the
work, which would have been nice... sigh...
(Assignee)

Comment 3

15 years ago
Created attachment 131134 [details] [diff] [review]
Second go at a patch

Comment 4

15 years ago
Comment on attachment 131134 [details] [diff] [review]
Second go at a patch

(I assume you've tested both plain text and html mail compose variations and
all the other message compose windows) r=brade
Attachment #131134 - Flags: review+
(Assignee)

Updated

15 years ago
Attachment #131134 - Flags: superreview?(bryner)
(Assignee)

Updated

15 years ago
Attachment #131134 - Flags: superreview?(bryner) → superreview?(scott)

Updated

15 years ago
Attachment #131134 - Flags: superreview?(scott) → superreview+
(Assignee)

Comment 5

15 years ago
Comment on attachment 131134 [details] [diff] [review]
Second go at a patch

Requesting approval on the basis that this fixes a recent regression.
Attachment #131134 - Flags: approval1.5?
(Assignee)

Comment 6

15 years ago
Fix checked into the trunk.

Comment 7

15 years ago
Comment on attachment 131134 [details] [diff] [review]
Second go at a patch

a=asa (on behalf of drivers) for checkin to the Mozilla 1.5 branch. Please add
the fixed1.5 keyword when this is landed on the branch. Thanks.
Attachment #131134 - Flags: approval1.5? → approval1.5+
(Assignee)

Comment 8

15 years ago
Fix checked into the trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Keywords: fixed1.5
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
Assignee: sspitzer → neil
You need to log in before you can comment on or make changes to this bug.