If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash, if you type into the overflow of a text area which has overflow:hidden set and then try to delete a number of characters.

RESOLVED DUPLICATE of bug 140256

Status

()

Core
DOM: Core & HTML
--
critical
RESOLVED DUPLICATE of bug 140256
14 years ago
14 years ago

People

(Reporter: marty kopka, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

A text area is created and the overflow attribute for it is set to hidden.  Then
text is set in that text area which flows past the end of the text area and goes
into the overflow area.  Holding down the delete key in the text area for ~10
characters causes the browser to hang indefinately.  

Below is a small sample file which I use to reproduce this.  Click on the text
area and hold down delete and the browser will hang.

Also, this problem occurs if rather than holding down the delete key there is an
attempt to change the value in the text area through the DOM.

ie : adding a button to the form which has an onClick() that calls a function to
do the following :

document.msgText.value = 'bla'; 

will also hang the browser.


Marty


<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <title>ta_test</title>
  <meta http-equiv="content-type"
 content="text/html; charset=ISO-8859-1">
</head>
<body>
<textarea class="noborder" name="msgText" rows="3" cols="16"
 wrap="physical" size="160" style="overflow: hidden;">dfskjh sdjhf
skjsdh fksjsdh fkjssdhff ks shd hkfhfjgsd f fkjsjshd h
fjgshskdjkdhjfskhskdj f fkhfkhsd f fkjsfkshd fkjfhssdkdkhjfgkssdhfksjd
f fkjfhssdkdjfsksjd fsdk</textarea>
</body>
</html>

Reproducible: Always

Steps to Reproduce:
See the details above for a step by step procedure how to reproduce this bug.

Actual Results:  
Browser hangs indefinately. Cant click on any buttons. Need to kill the browser.

Expected Results:  
Allow you to delete all characters without hanging. 
Allow you to overwrite the text area value through the DOM without hanging.
Created attachment 126977 [details]
Testcase from the reporter
Created attachment 126978 [details]
Stacktrace

I get a crash after deleting the last char.
Using an one day old cvs trunk on win2k (optimized with symbols)
and duping

*** This bug has been marked as a duplicate of 140256 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.