Closed Bug 21156 Opened 20 years ago Closed 20 years ago

assert in nsFrame::AppendFrames when going to this url

Categories

(Core :: Layout, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

()

VERIFIED DUPLICATE of bug 20468

People

(Reporter: Brade, Assigned: troy)

References

()

Details

I see an assert (4 actually) with today's build when I load this URL:  http://
companies.netscape.com/item.cfm/c1208082.300?heads=yes&source=mn
(or click on the news item for Microsoft joining forces on mobile internet from
http://my.netscape.com)
Assignee: troy → brade
I can't reproduce this why today's build.

Can you provide some additional information so I can determine who should get
the bug?

Thanks.
Assignee: brade → troy
The assertion is:
###!!! ASSERTION: not a container: 'PR_FALSE', file nsFrame.cpp, line 332

This is inside nsFrame::AppendFrames
This is called from (partial stack):
 * FrameManager::AppendFrames
 * nsCSSFrameConstructor::AppendFrames
 * nsCSSFrameConstructor::ContentAppended
 * StyleSetImpl::ContentAppended
 * PresShell::ContentAppended
 * nsDocument::ContentAppended
 * nsHTMLDocument::ContentAppended
 * HTMLContentSink::NotifyAppend
 * SinkContext::FlushTags
...

I can still reproduce this on Mac with a build from today
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Eric, the page has an IFRAME in it so I think this is a DUP of bug #20468

*** This bug has been marked as a duplicate of 20468 ***
Status: RESOLVED → VERIFIED
Agreed. Marking verified dup of 20468.
You need to log in before you can comment on or make changes to this bug.