If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Core
Printing: Output
--
enhancement
RESOLVED DUPLICATE of bug 201737
14 years ago
14 years ago

People

(Reporter: Peto, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

Mozilla should be able fill-in URLs of links mentioned on page and then print it
together with the original site content.

Reproducible: Always

Steps to Reproduce:
1.go to some site with links
2.try to print
3.

Actual Results:  
Site is printed, but on paper version, the information about URLs of links is lost.

Expected Results:  
Mozilla should have function (say URL printing on/off) that will insert URLs
after link names to the original page and print it together.

One possible way to do it with less harm to original site is that Mozilla will
add only numbers, directly after link names, font-differentiated, and on the
very bottom of printed pages will be index with number and URL.

More sofisticated engine will compare URLs and find the repeating ones and use
only one number for them. There could be also an option to limit maximum length
of URL to some extent, for example 100 bytes. Also some formatting protection
should not harm to prevent special formatting symbols to be printed that will
result in huge blank spaces or corrupted text. For example, filter will pass
only standard printable characters, others will not be sent to printer.

I know this all is quite complicated, for example, to add URL index even for
pictures, because this would affect the whole page. First approach could be to
solve this for links appearing inside text, and then try to do it for images
too. An option should be avaiable to switch image and text links printing
separately on/off. For example, if I know that images URL indexing would corrupt
the page, I will enable only text links indexing. And so on..

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 201737 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.