Closed Bug 211589 Opened 21 years ago Closed 21 years ago

navigation buttons disabled on javascript launched windows

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: coscatmu, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

When a window is launched via JavaScripts window.open function, the navigation
buttons appear to be disabled on the newly launched window.  

Reproducible: Always

Steps to Reproduce:
1. Download attachments and save in same directory.  
2. Load the "nav_disabled.html" into the browser
3. Click on one of the "Open Separate Window" links.
4. Click on one of the resultant links (google or mozilla.org)

Actual Results:  
Note that the back button is not enable to let you go back to the link list that
shows your options.  You can only shut down the window and go back to step 3
which will open a new window again.

Expected Results:  
When I clicked on either the google or mozilla.org link, I should be able to go
back to my page with a list of links.

History = 9 days in the config.
Cache = 20 MB.

*** This bug has been marked as a duplicate of 18808 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
I don't see this as a duplicate of 18808.  Try this:

1) Open two mozilla windows.
2) In the first one.  Open the nav_disabled.html
3) In the other window, do a File | Open on links.html (see attachment)
4) Click on one of the links in the first window which will launch a new window
with links.html in it.

Now, if you click on either the google or mozilla link in the non-spawned
window, the nav buttons are enabled allowing you to go back to links.html.  
However, if you perform that same action in the spawned window, the nav buttons
are never enabled.

I'm not asking for the nav history to inherit from the parent window.  I'm only
asking that it keep track of it's local history and in the case presented in the
attachment, that is not happening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Sorry, my bad. I should have read better the description.

Moving to DOM level 0 where this is probably better placed.

Anyway I think that this is invalid: in the function that opens the new window
the contents gets written with a frameset, but it's never closed.

Changing the code to
		extWindow = window.open('',
'',"location=yes,resizable=yes,toolbar=yes,menubar=yes");
		extWindow.document.open();
		extWindow.document.writeln('<html><frameset rows="25,*" frameborder="0"><frame
frameborder="0" name="returnbar" src=""><frame frameborder="0"
name="ext_content" src="'+targetHTML+'"/></frameset></html>');
		extWindow.document.close();

makes it work fine for me.
Assignee: radha → dom_bugs
Component: History: Session → DOM Level 0
QA Contact: petersen → ashishbhatt
You're right.  document.close() fixes the behavior.  This is just another case
where Mozilla is implementing the standard more strictly than other browsers and
what appears to be a bug is not.  I resolved this and marked it as INVALID. 
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: