incorrect behaviour with right-to-left text box

VERIFIED INVALID

Status

()

VERIFIED INVALID
16 years ago
12 years ago

People

(Reporter: rfine, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; BTinternet V8.4)
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

The text box on the Google Mirror (http://www.alltooflat.com/geeky/elgoog/) is 
demonstrating incorrect behaviour. I can't see anything special about the code, 
so I'm guessing it will happen with all right-to-left text boxes.

Firstly, the box renders text exactly as if it were a plain text box, merely 
right-aligned. If I type the keys 'hello' I would pretty much expect to 
see 'olleh' in the box, with the cursor at the left end of the word. The cursor 
stays at the right end of the box until I press the spacebar, when it 
momentarily jumps to the left end. The next word I type jumps it back to the 
right.

Secondly, pressing 'Home' on the keyboard (causing the cursor to jump to the 
right, correctly) followed by the:
 left arrow key: causes a freeze.
 right arrow key: causes the cursor to jump to one character in from the left 
side.
Similarly, 'End' followed by the:
 left arrow key: causes a freeze.
 right arrow key causes the cursor to jump to the right end of the box (as 
if 'home' had been pressed. Ironically, due to the previous problem, continued 
presses of the right arrow key behave correctly).

Reproducible: Always

Steps to Reproduce:
1. Head over to http://www.alltooflat.com/geeky/elgoog/
2. Type several words into the box. Observe how the cursor jumps about.
3. Hit 'Home' and press the right arrow key a few times. Hit 'End' and repeat.
4. Hit 'Home' or 'End' and press the left arrow key. (Note: this will crash 
your browser).

Actual Results:  
Browser freezes. (Ctrl-Alt-Del, kill process required).

Expected Results:  
1) When typing words, the text should effectively be shown in reverse, and the 
cursor should stay with the current text insertion point, at the left end of 
the user's text.
2) When the 'Home' key is pressed followed by the Right arrow key, nothing 
should happen. When the 'Home' key is pressed followed by the Left arrow key, 
the cursor should move one character to the left.
3) When the 'End' key is pressed followed by the Right arrow key, the cursor 
should move one character to the right. When the 'End' key is pressed followed 
by the Left arrow key, nothing should happen.

Comment 1

16 years ago
Not a bug, the page does exactly what it is intended to do. This is a normal
right-aligned text-field, which does not feature a character reversing. This
functionality would have to be implemented via javascript, which has not been
done here.

I also can't reproduce your crashes here with my 20030702 build on W2K. Get a
current nightly-build and start it with a fresh profile (and without any
additional themes and extensions) and test it again. Please reopen this bug, if
you are still experience crashes with a new build and a new profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Summary: incorrect behaviour (and sometimes crash) with right-to-left text box → crash with right-to-left text box
(Reporter)

Comment 2

16 years ago
Tried this on the nightly build, and it doesn't crash.

However, the cursor still exhibits odd 'jumping' behaviour. If you press and
hold the right arrow key to scroll through text in the box, it keeps wrapping
(which it shouldn't be doing).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: crash with right-to-left text box → incorrect behaviour with right-to-left text box
(Reporter)

Comment 3

16 years ago
(changed severity down to normal, because this is a behaviour oddity rather than
a full crash)
Severity: critical → normal

Comment 4

16 years ago
This still isn't a bug. The cursor jumping is intended. That's how right-to-left
text boxes work. Try IE (I tested with IE 5.5) or any other browser. They will
do exactly the same.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID

Comment 5

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.