All users were logged out of Bugzilla on October 13th, 2018

Java holds onto text input even if focus is elsewhere

VERIFIED DUPLICATE of bug 247140

Status

VERIFIED DUPLICATE of bug 247140
16 years ago
8 years ago

People

(Reporter: mysterioususer, Assigned: joshua.xia)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030703
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030703

When using a java applet with a text box in it, the applet steals the focus for
text input, even if it shouldn't.

Reproducible: Always

Steps to Reproduce:
1. Open a java applet with a text input box.  Click inside the text input.
2. Try changing what's in your text input box.  Everything is happy, right?
3. Open a new tab.  It doesn't have to have anything loaded in it.  Click in the
URL box.  Type a URI.

Actual Results:  
The website intended to show up in the location box instead showed up in the
text box of the page with a text box that I had switched out of.

Expected Results:  
The text should have stayed within the location bar.

Comment 1

15 years ago
I can confirm this behaviour. It affects Netscape 7.1 for Mac OS X, as well as
the latest Mozilla and Firefox builds for Mac OS X.

Comment 2

15 years ago
Additionally, elements of the Java applet then suddenly appear, where they
shouldn't. For demonstration, I made two screenshots, one from a page with a
Java applet, the other one from Bugzilla with overlayed elements from the applet
in the other tab.

I sometimes have focus problems with mozilla on Mac OS X, so maybe this is not
only a Java problem and this bug might be related to bug 237038.  

Comment 4

15 years ago
Created attachment 143820 [details]
Bugzilla page overlayed with elements from Java Applet

Comment 5

14 years ago
You don't have to have a text entry box in the applet for this to happen. For
instance, in Smartmoney.com having their applet to display a portfolio will
prevent you from entering a stock symbol. 

Comment 6

14 years ago
*** Bug 230131 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 266065 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
I found a confirmed bug.

*** This bug has been marked as a duplicate of 247140 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 9

14 years ago
This is marked resolved? it stills happens for me under the RC2 build. Easily
reproducable. Just create an applet with a JTextField. click on the JTextField
to gain focus then you cant type anywhere else in the browser. Eventually FF
will crash.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.