Vertical scrollbar is not triggered by table overflow

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: S Woodside, Unassigned)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

1.06 KB, text/html
Details
(Reporter)

Description

15 years ago
cannot view lower part of page. Looks fine in Safari 1.0. Tested with Camino
recent nightly and Mozilla 1.4 (mac os X)

Comment 1

15 years ago
The problem is that the DIV tag that holds all of the main content looks like this:

<div align="center" style="width: 593; height: 543">

The height is set to an absolute, and Mozilla truncates the content that extends
beyond it.  I'm not sure if this is expected or not (I suspect it is) because
it's a quirks-mode document with an invalid CSS definition here (since there is
no unit to go with the numbers for width/height).

Changing OS/Platform to all/all since I see this in 20030627 PC/WinXP.
OS: MacOS X → All
Hardware: Macintosh → All

Comment 2

15 years ago
Created attachment 127035 [details]
Testcase

Comment 3

15 years ago
Still, overflow should be visible, but it actually looks like the table is
trying to wrap the content.  -> Tables.
Assignee: other → table
Component: Layout → Layout: Tables
Keywords: testcase
QA Contact: ian → madhur

Comment 4

15 years ago
*** Bug 211774 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
regression between linux trunk 2002121812 and 2002121908
Keywords: regression
Bug 172896, of course.  But that only means it's a duplicate of bug 173277.

Comment 7

15 years ago
*** Bug 215298 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
*** Bug 217637 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
*** Bug 218503 has been marked as a duplicate of this bug. ***
*** Bug 218659 has been marked as a duplicate of this bug. ***
This is mostly fixed by bug 173277, however the viewport vertical scrollbar does
not appear until I trigger a reflow.
Severity: major → normal
Keywords: testcase
Summary: cannot view lower part of page → Vertical scrollbar is not triggered by table overflow
Created attachment 131444 [details]
Testcase #2
Attachment #127035 - Attachment is obsolete: true

Updated

15 years ago
Blocks: 194822

Updated

15 years ago
Keywords: testcase
Mats, are you still seeing a problem on that testcase?
WFM, 2004-02-20-08 trunk Linux.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
No longer blocks: 194822
*** Bug 194822 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
http://www.ee.buffalo.edu/people/faculty/index.html

the table now displays properly.  But anything after the table is displayed in
the middle of the table, where mozilla was truncating the table originally. 
Look for the two lines that say:

"Copyright 2002-03 State University of New York at Buffalo Electrical &
Engineering Department
Questions or Comments about this site contact: Webmaster"

These are displayed in the middle of the table, when they should be displayed
directly after.  For me the lines are displayed in the middle of the picture for
Alexander Cartwright.
Greg, that's the right behavior when a box overflows in the CSS layout model.
See bug 218659 comment 2 for the bad styling.
You need to log in before you can comment on or make changes to this bug.