auspost.com.au - cross browser UL margin rendering issue

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
16 years ago
4 years ago

People

(Reporter: a.frith, Unassigned)

Tracking

Details

(Whiteboard: [bug248549notfixed], URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

this page renders incorrectly in Mozilla, but correctly in IE.  The leftmost
column overlaps the middle column, so all the text on the page can't be seen. 
Reloading doesn't fix it.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL http://www.auspost.com.au/BCP/0,1080,CH2481%257EMO19,00.html

Comment 1

16 years ago
That looks like correct behavior to me, at a quick glance.  Each UL in the
leftnav has the style:

 .leftnavul 
{
	margin-left: 20px;
}

So each bullet list is getting progressively indented 20px, until it's running
over the next column.
This is evang. The indentation of <ul> is done by a margin in IE but a padding
in Mozilla, so the site making the indent much bigger in mozilla (60px) while
making it smaller in IE (20px).
Assignee: table → english-other
Status: UNCONFIRMED → NEW
Component: Layout: Tables → English Other
Ever confirmed: true
OS: Windows XP → All
Product: Browser → Tech Evangelism
QA Contact: madhur → english-other
Hardware: PC → All
Version: Trunk → unspecified

Comment 3

16 years ago
Updating summary.
Summary: page with tables rendering incorrectly → auspost.com.au - cross browser UL margin rendering issue

Updated

14 years ago
Whiteboard: [bug248549notfixed]

Comment 4

12 years ago
(In reply to comment #2)
> This is evang. The indentation of <ul> is done by a margin in IE but a padding
> in Mozilla, so the site making the indent much bigger in mozilla (60px) while
> making it smaller in IE (20px).

I can see that, but does anyone has a solution to this?
I could change my css file tu a .php.css but then I'd have change the link in all the pages and the pages are too many, and the site is in three languages, so multiply the number of sections by three, changing them would be a pain in the butt.
The same if I use 2 different stylesheets one for IE and the other for Firefox in using js.

SO:
Is there a solution using only css??

Comment 5

12 years ago
That was stupid, I admit it, asking without trying. I'm sorry, my bad.

For the ones that r still seeking the answer, I did this and it worked:

ul {margin-left: 15px; padding-left: 15px}

The IE will ignore the padding measure and use only the margin, and Firefox will ignore the margin and use only the padding.
This is what works for me. Hope it works for you and other versions of Firefox and IE.

This are the versions I'm using of IE ad FF

Firefox Version: 2.0b 2
IE Version: 6.0.2900

Comment 6

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.