stops operating normally from time to time (can't open new windows, follow the links, etc), though doesn't hang

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: mail, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

At some points (can't reproduce) browser won't respond to the link clicks (just
does nothing instead of loading new page) or keyword shortcuts for new
window/tab (CTL-N, CTL-T). Mozilla doesn't hang, but you are virtually stuck
with the pages you loaded and can't load anything else.

NOTE: after you close Mozilla, you still see Mozilla process still hanging in
the memory (QuickStartup turned off), so have to kill it manually just to run
Mozilla again.

Reproducible: Couldn't Reproduce

Steps to Reproduce:




Such things used to happen pretty often in 1.0 releases, but not in 1.3.1. With
the newest 1.4 stable release i was running into such 'hanging' 3 or 4 times for
the last hour or so.

OS: WinXP, SP1

Probably this happens more often when visiting badly formed HTML, but not 100%
sure. Also, MEM occupied by that stray Mozilla process I had to kill was around
100Mb.

Comment 1

15 years ago
I think I can reproduce at least one situations in which one of the problems
arises.  After pressing the "Stop" button immediately after clicking a link, the
link will no longer function.

I'm running:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030911
Firebird/0.6.1+

The steps below are not specific to the given website/link.  I'm pretty sure any
site will work.

Steps to Reproduce:
1. Go to http://www.w3.org/
2. Click on "Accessibility" (on the left-side navigation area) and press the
Stop button in the browser immediately after (i.e. before the link is followed).
3. Now try using the "Accessibility" link.  It doesn't function anymore.

Note that the original report also says that Ctrl+N and Ctrl+T stop working in
some cases.  The above steps do not produce this condition.
Both cases WFM on WinXP trunk 2003102804.

Reporter/Kannan: could you please try this again using a recent nightly build
from <http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/> ? If it
works, please resolve this bug as WFM. Thanks !

Comment 3

15 years ago
WFM
Firebird 0.8.0+ (20040130)

Please try to reproduce this bug with a newer build.

Comment 4

15 years ago
Marking this as WFIf you canreproduce it with a new build, then please reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.