Closed Bug 211692 Opened 17 years ago Closed 14 years ago

Cannot move or delete bookmarks

Categories

(SeaMonkey :: Bookmarks & History, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: odungey, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030410
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030410

I am not quite sure when this happened but I cannot delete or move any bookmarks
(through the manager or sidebar). Strangely I can edit properties of bookmarks
like the name and location.

Reproducible: Always

Steps to Reproduce:
1.try and delete a bookmark in many ways
2.try and move a bookmark in may ways
3.

Actual Results:  
Nothing, no errors, no beeps, plain and simple nothing-at-all

Expected Results:  
A bookmark should have moved or deleted
Same problem here on Linux (Debian 3.0, packages from http://debian.relativ.org/).
The file permissions are OK, the problem even exits on new created accounts.
I can confirm this with the following versions:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030714 Debian/1.4-2
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030618

Editing the properties works, but moving or deleting bookmarks not. Filing new
bookmarks also works. I also tried moving away the bookmarks.html file and
re-importing the bookmarks; it still doesn't work.

Raising severity to major.

Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
I also just tried to create a new profile and added two new bookmarks.
It's also not possible to move or delete them.
Summary: Cannot move or delete bookmarks after upgrade → Cannot move or delete bookmarks
Hi everyone,

It seems like this was a problem with the Debian package only. Have a look at
http://bugs.debian.org/cgi-bin/bugreport.cgi?archive=no&bug=200506
for more details.

The latest mozilla-browser package apparently has a fix for this.

If one of you is NOT using Debian, then I'll stand corrected. Otherwise, this
bug report can probably be closed.
Robin: thanks for the info. This bug was originally reported on Windows NT so
I'll keep it open.
We had a similar problem will browser-only seamonkey installation.
I think Jan fidex this issue. Jan could you confirm/dupe it?
Oliver, Stephan: do you still have this problem? 
See comments #4 and #5.
I'm seeing "unable to move/delete" and then some in 1.6 under the following
situation:
* Create a new bookmarks folder called "Junk"
* Use any of the bookmark search facilities to search for a subset of your bookmarks
* move some of the subset into the junk folder
* go back to the full bookmarks view
* delete everything in the junk folder
* now search again

result: you now have two copies of each bookmark you junked, except one of them
is apparently invisible in the main folder view. the original bookmark stays
right where it is, despite the move operation.

moving a bookmark /without/ doing the search first results in the original
bookmark disappearing from the list but it still shows up in search results.
I switched from Mozilla 1.5 to Mozilla 1.7b:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040421 MultiZilla/1.6.3.2f

And now I can't move/re-order my bookmarks as I always used to do. When I try to
drag with mouse a bookmark to another place, I got always the "crossed circle"
meaning I can't drag'n drop.

The problem is with the bookmarks sidebar and the bookmark manager.

Otherwise I can delete bookmarks.
[Continuation of comment 8]

I wondered if the problem could be a side-effect of an add-on, so I uninstalled
Mozilla 1.7b and made sure the folder was empty. Then I reinstalled it and the
problem is still there (one strange thing is that multizilla is already
available together with the googlebar; but optimoz and enigmail are really
missing???)

I noticed also that I can still move/re-order my bookmarks by using the
Bookmarks menu. So I think I will start using it ;-)
(In reply to comment #9)
> I reinstalled it and the
> problem is still there (one strange thing is that multizilla is already
> available together with the googlebar

So obviously not everything is uninstalled, maybe it's in your profile?
Please try creating a new profile for testing.
I can confirm this bug has been around on Win98se since Moz1.6
Confirmed on: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4) Gecko/20040927
MultiZilla/1.6.3.0e
Had no problem with 1.7.0

Product: Browser → Seamonkey
resolved?  Oliver?
I fixed my problem by putting Mozilla in the bin and getting Firefox instead. 
To my knowledge this is still a howling bug in Mozilla.
WFM  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050913
SeaMonkey/1.1a

Is the problem only in *nux?
Assignee: p_ch → nobody
QA Contact: chrispetersen → bookmarks
latest version works for Bernhard on *nix.
marking WFM.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.