Some left (double) clicks on the bookmarks toolbar folders are ignored

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Stephane Chauveau, Assigned: Pierre Chanial)

Tracking

unspecified
x86
Linux
Points:
---
Bug Flags:
blocking-aviary1.0PR -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030630 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030630 Mozilla Firebird/0.6

Clicking on a folder name in the bookmark toolbar does not always open or close
the corresponding menu.  The problem seems to be related to the double click
detection. 

Reproducible: Always

Steps to Reproduce:
1. Create a bookmark toolbar with a least 2 folders
2. Open the menu of the first folder
3. Click on the second folder name. This should close the first menu
4. Immediately click a second time to open the second menu. 

If you are faster than the 'Double click Delay' then nothing happens. 
You may have to click a third time or even a fourth time to finally 
open the menu. I find this anoying because it gives the impression that
Firebird is not responsive. 

This behavior is easier to reproduce with a high 'Double-click Delay'.









My system characteristics are 
  Linux 2.5.67 - Debian Unstable - Gnome 2.2 - XFree86 4.3 - Sawfish

Comment 1

15 years ago
*** Bug 211745 has been marked as a duplicate of this bug. ***
WFM on win2k builds, even with mouse delay slowed way down.  Can this be
reproduced on Mozilla trunk builds?
Summary: Some left (double) clicks on the bookmarks toolbar folders are ignored → Some left (double) clicks on the bookmarks toolbar folders are ignored
(Reporter)

Comment 3

15 years ago
I just downloaded the latest nighties for Mozilla and FireBird (2003070408)
and the problem appears to be gone so I consider it resolved. I will check
Firebird 0.7 as soon as it is released.  

For the record, I was also able to reproduce this on Mozilla 1.3.1 (Linux). 
(Reporter)

Comment 4

15 years ago
It may not be solved after all! The Debian version of Firebird 
uses gtk2 while the nightlies are still built with the outdated 
gtk1.2.  
I cannot consider the problem solved unless I can verify it on 
a recent build using gtk2.


 
Stephane, try a nightly build from the timeframe that was failing (i.e. 0630)
and see if the problem exists in that build.  If so, the bug is indeed fixed.

On the other hand, if that is not the case and you cannot replicate this with
older nightly builds, please provide as much information about the build
options/environment for the failing builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

15 years ago
I could not reproduce it with the nightly 0630-17.

I don't have a lot more information about this build. This is
the current official Debian package mozilla-firebird_0.6-8_i386.deb

you can get more information about this package at
http://packages.debian.org/unstable/web/mozilla-firebird.html

My opinion is still that this related to gtk2.

PS: dont bother to ask more info during the next 2 weeks! I am out :-) 
(Reporter)

Comment 7

15 years ago
I just installed the latest Debian package for Mozilla 1.4 (not firebird) 
and the problem is still there:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030704 Debian/1.4-1

This is also a gtk2 build!
I reopen.

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Updated

15 years ago
Depends on: 214652

Updated

15 years ago
Blocks: 214652
No longer depends on: 214652
Confirming for now, GTK2-specific
Status: UNCONFIRMED → NEW
Ever confirmed: true
Definitely can confirm using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b)
Gecko/20030825 Mozilla Firebird/0.6.1+ official GTK2+XFT build

Odd little bug...

Updated

14 years ago
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR-
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
Some time in the intervening 3.5 years, we seem to have started opening toolbar menus on hover, so it's not possible to click on the second to close the first, what with the way the first closes and the second opens as so as you come near it.
Status: NEW → RESOLVED
Last Resolved: 15 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.