If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nested table stop rendering with automatic height in outer table

RESOLVED DUPLICATE of bug 211641

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 211641
14 years ago
14 years ago

People

(Reporter: Pauli "suokko" Nieminen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

In http://antin.net/keulatiimi/kalenteri1.shtml should inner tables continue
about 6 times more than mozilla renders.
There is outer table without height parameter. Mozilla **** height of that
outer table much under needed size. It continue rendering of inner tables over
border of outer table. Image under outer table is placed to 'right' position
after table. (I mean it's immidiatly after border of outer table; inner tables
don't affect to it)

Inner tables doesn't seems to affect to height of outer table (I have try to
delete some rows in inner tables but height od outer table seems to be same allways)

simplified example of page:
<div>
<table>
  <div>
  <!- some data which render corectly -->
  <table>
  <!- many rows -->
  </table>
  <table>
  <!- many rows -->
  </table>
  <table>
  <!- many rows -->
  </table>
  <table>
  <!- many rows -->
  </table>
  <table>
  <!- many rows -->
  </table>
  <table>
  <!- many rows -->
  </table>
  </div>
</table>
</div>

There is much style stuff and coloring but I try to delete some of them but that
didn't help anything.

Reproducible: Always

Steps to Reproduce:
Solution:
A) When I delete oute table all inner tables are rendered correctly! I haven't
found any othes sollution.

B) Putting heigt to outer table doesn't help!
Actual Results:  
A) corerct rendering except borders missing in page.


B) Page will be rendered like inner tables doesn't have any height. It try to
render everyting to middle even when height od oute table is too small for inner
tables and inner tables are rendered over areal (mean half visible rendering) 

Expected Results:  
Mozilla should calcualte height of everything inside outer table and use that as
height of auter table.


Problem seems to be now that for some reason momzilla stop calculation too early
and height of outer table is too small. I haven't yet learnt to read code of
mozilla so I cannot give the real reason. (I don't have time to begin develop
mozilla just now)

I will try to help as much a s I can if someone will begin to search this bug in
code.

If there is anything which aren't understandable I try rewrite that part if you
point it out.
(Reporter)

Comment 1

14 years ago
Created attachment 127078 [details]
nested table where problem is
(Reporter)

Comment 2

14 years ago
Created attachment 127079 [details]
same nested table without outer table (page should look like this)

I just note that image under nested table are rendered over inner tables now.
It seems to be same position as with outer table.

Comment 3

14 years ago
Could be related to bug 88035.
(Reporter)

Comment 4

14 years ago
line just before inner talbes was the problem:

      <div align="center" style="width: 768px; height: 995px;">


That height part made inner tables seems like 995 pixels high. Now we can see
why shouldn't use frontpage. Much too much stuff which only makes problems. I
found that line because it was just before a center line. I haven't created this
page so it was hard to found real reason when I got job to check it.

Thanks for help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 5

14 years ago
This is actually a bug in Mozilla - overflow should be visible.
Opening to mark it as dupe of bug 211641...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 211641 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.