If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Installing French pack 1.4 over Mozilla 1.3.1 is accepted, it says success, but it does not work and creates problems

RESOLVED INVALID

Status

Mozilla Localizations
fr / French
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Lumina, Assigned: David Bellot)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3.1) Gecko/20030425

Hello,

I had Mozilla 1.3.1.
I heard that 1.4 was out. So I went here to found a French version :
http://www.mozilla.org/projects/l10n/mlp_status.html#moz_1.4
I clicked on the French version for 1.4, it asked me if I wished to install it,
I said yes, and it says that the installation was successfull.

But then :
- I am still in 1.3.1 US
- Half the window is hidden with strange things

Reproducible: Didn't try

Steps to Reproduce:
1. Have Mozilla 1.3.1 US
2. Try upgrading to 1.4 French (it will success...)
3. Close Mozilla and open it again

Actual Results:  
- I am still in 1.3.1 US
- The low half of the window is hidden with those phrases :

<menuitem id="menu_inspector" label="&inspectorTaskCmd.label;"
----^

<menuitem position="5" label="&venkmanCmd.label;"
--^

<key id="key_irc"  key="&ircCmd.commandkey;" command="Tasks:IRC" modifiers="accel"/>

I don't know how to resolve it, and why this happened. If I installed something
wrong, why it didn't checked the version compatibility and stoped me ?

Expected Results:  
Instead, Mozilla should have upgrade to 1.4 French.
Or there should have been a warning saying :
"installation canceled, you have the wrong version of Mozilla, please go here to
find the correct file for your update"

Comment 1

13 years ago
You shouldn't try to install *only* a language pack to upgrade your version of
Mozilla. First upgrade to the new version, then apply the language pack. Or,
probably better, use the full distribution to your platform.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
My request was to have a warning that would cancel the installation process if 
the detected version of Mozilla is wrong.
You need to log in before you can comment on or make changes to this bug.