How to determine the memory cache size on multi-user operating systems with memory quota based on user profiles.

RESOLVED DUPLICATE of bug 204164

Status

--
enhancement
RESOLVED DUPLICATE of bug 204164
16 years ago
14 years ago

People

(Reporter: munk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; OpenVMS AlphaServer_DS10_466_MHz; en-US; rv:1.4) Gecko/20030625
Build Identifier: Mozilla/5.0 (X11; U; OpenVMS AlphaServer_DS10_466_MHz; en-US; rv:1.4) Gecko/20030625

This bug report is a generalized follow-up on bug 210481. That bug is about
determining the memory cache size on OpenVMS.

At present the memory cache size is based on the size on the internal memory of
the system. However this is not the correct approach for OpenVMS, and most
likely not for certain or situations as well.

First a small explanation about OpenVMS. On this operating system every user has
a user profile that sets limits to the use of system resources, incl. physical
and virtual memory. The limits in these profiles are not optional, they always
exist. Only the size of the limits can vary of course. The limits also exist for
the user System, the OpenVMS equivalent for the Unix Root account.

That means that the maximum memory cache size must be calculated by using the
memory size limits from the use profile, and not by using the physical memory
size of the system. I'm the happy owner of Alphaserver with 1 GB memory and
running OpenVMS, so I can make a nice profile for myself that allows me to use a
200MB cache if I like. Should 10 user work on this system (and that is quite
possible) the memory quota in profiles would allow for a cache szie of maybe 10MB.

Now to the more general problem. As I have been made to understand it is also
possible to set resource quota on user profiles on Unix systems. In a situation
that these quota exist on a Unix system, a similar memory cache calculation as
described for OpenVMS should be made here too. 

In order to avoid making a unique memory cache calculation for OpenVMS, it would
be more appropiate to make a more general calculation for similar setups, be it
with OS specific calls.  

   



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 204164 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.