When building on xcode, should use pbbuild instead of pbxbuild

RESOLVED FIXED

Status

SeaMonkey
Build Config
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: Brian Ryner (not reading), Assigned: Brian Ryner (not reading))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
For XCode, Apple changed the name of the command-line tool to build a
ProjectBuilder project from 'pbxbuild' to 'pbbuild'.  We should auto-detect
which one is present and use it.

This patch also includes a change we'll need for building on Apple's gcc 3.3 -
the meaning of -traditional-cpp has changed.  What we really want is
-no-cpp-precomp (the two options are identical on older developer tools; nspr
and ldap already use -no-cpp-precomp).
(Assignee)

Updated

15 years ago
Attachment #127131 - Flags: review?(sfraser)

Updated

15 years ago
Attachment #127131 - Flags: review?(sfraser) → review+
(Assignee)

Comment 2

15 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
*** Bug 211714 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.