The Documentation about the installation of Bugzilla 2.17.4 on Windows is not comprehensive enough

RESOLVED DUPLICATE of bug 239852

Status

()

Bugzilla
Documentation
P2
enhancement
RESOLVED DUPLICATE of bug 239852
15 years ago
6 years ago

People

(Reporter: Clement, Unassigned)

Tracking

2.17.4
x86
Windows 2000

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: 

[First I apologize for my bad English]
I have tried (and succeeded) to install Bugzilla on Windows 2000 following the 
instructions of The Bugzilla Guide - 2.17.4 Development Release 
(http://www.bugzilla.org/docs/html/). Sadly I had a lot of problems that I 
resolved thanks to the great help of many people on the 
netscape.public.mozilla.webtools newsgroup. So I think my newby comments can be 
useful in order to improve the Win32 part of the installation guide.

So here are the few points that I would have appreciated to read in the doc:

* about the Perl modules requirements:
  * I had to download both AppConfig (which was not written in the doc)
    and Template-Toolkit from OpenInteract and it was really hard to find
    where to download them (http://openinteract.sourceforge.net/ppmpackages/)
  * I have not found the Data-Dumper and Text-Wrap modules but they were already
    installed in my ActivePerl installation
  * I had to add a local repository because I couldn't download the modules
    (because of a Firewall)
  * I had to install TimeDate, which is not clearly explained in the docs
  * Because of dependencies, I had to install Getopt-Long and IO-Stty 
* about the Perl interpreter
  * I had to change the interpreter path (C:\perl\bin\perl) in all script files
    because there was no way to use the ScriptInterpreterSource Registry option.
    I don't have really understood why but Dave Miller told me to do so. So
    I did :o)
* about the modifications of checksetup.pl
  * I had to follow the instructions found in the newsgroup to make it work. I
    think that the instructions of this post should be added to the doc:

    http://groups.google.com/groups?dq=&hl=en&lr=&ie=UTF-8&threadm=WQwHa.5280%
    24vq.1613%40sccrnsc04&prev=/groups%3Fdq%3D%26num%3D25%26hl%3Den%26lr%3D%
    26ie%3DUTF-8%26group%3Dnetscape.public.mozilla.webtools%26start%3D50

* about the localconfig file
  * I had to replace
        $mysqlpath = "C:\mysql\bin\mysql";
    with
        $mysqlpath = "C:\\mysql\\bin\\mysql";

That's all :o) I may have seemed a bit critic but I really appreciate your work 
and I hope that my (un)experience can be useful to others. I really don't know 
anything in Perl, MySQL, Win32 admimnistration, etc so I think that once all 
these things will have been added to your doc, *all* people will be able to 
install Bugzilla on Windows without *any* problems.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
I have forgotten one thing:
* I had to delete "by hand" C:\Perl\lib\CGI.pm in order to install the
  newer CGI package.
Version: unspecified → 2.17.4

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.18
(Reporter)

Comment 2

15 years ago
Sorry another update:
I've written that IO-Stty was needed, this is wrong, sorry again.
Actually, it should be needed if we fix checksetup.pl to be able to fix the
administrator account properly on Windows.  (but that's another bug)
(Reporter)

Comment 4

15 years ago
Last things before I stop my work on Bugzilla:
* You should give the address of this repository for ppm packages:
  http://theoryx5.uwinnipeg.ca/ppms/
* It was not clearly mentionned that Net SMTP was already installed in
  ActivePerl
* I couldn't find a package of the Chart module so I had to compile it by myself

OK, this was my last message (I'm leaving the company), long life to Bugzilla 
and keep doing  this great work (I hope my comments have been a bit useful).
(Reporter)

Comment 5

15 years ago
Very very last update :o)
Thanx to the work of Peter, it seems that the information contained in this 
post is very useful too:

http://groups.google.fr/groups?dq=&hl=fr&lr=&ie=UTF-
8&threadm=b37bc72c.0308050811.6154dfc2%40posting.google.com&prev=/groups%3Fhl%
3Dfr%26lr%3D%26ie%3DUTF-8%26group%3Dnetscape.public.mozilla.webtools

Comment 6

15 years ago
I likewise had a bit of trouble getting things going on windows 2000 but
eventually figured out how to get "ScriptInterpreterSource registry" going in a
reproducable way.  

*To httpd.conf add the line
ScriptInterpreterSource registry

*To the registry, either ensure the following key exists or create it yourself
with the relevant location of Perl.
HKEY_CLASSES_ROOT\.pl\Shell\ExecCGI\Command D:\Perl\bin\Perl.exe -wT "%1" %*

where HKEY_CLASSES_ROOT\.pl\Shell\ExecCGI\Command is the key
and
D:\Perl\bin\Perl.exe -wT "%1" %* is the default value.

Note this will run perl in Taint mode which will cause a few scripts to fail. 
The latest one I found being editkeywords.cgi see Bug 224126
Jake is leaving for a while (Reserve unit got called up), and we don't have a
new docs owner yet.  Anyone interested in helping out, please add
documentation@bugzilla.org to your watch list in your email preferences in Bugzilla.
Assignee: jake → documentation
Enhancements which don't currently have patches on them which are targetted at
2.18 are being retargetted to 2.20 because we're about to freeze for 2.18. 
Consideration will be taken for moving items back to 2.18 on a case-by-case
basis (but is unlikely for enhancements)
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Preliminarily moving all docs bugs to 2.18, we should make a valiant attempt to
have the docs as up-to-date as possible when 2.18 releases.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.18
I realize I'm duping this the wrong direction, but the other bug is essentially
the same thing, and already has several patches in progress on it.

*** This bug has been marked as a duplicate of 239852 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.