Error 221: "TypeInState.h", line 71 # Member 'UpdateSelState' not declared

VERIFIED DUPLICATE of bug 209395

Status

()

Core
Editor
--
blocker
VERIFIED DUPLICATE of bug 209395
15 years ago
11 years ago

People

(Reporter: zvonik, Assigned: Joe Francis)

Tracking

({regression})

Trunk
HP
HP-UX
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.4a) Gecko/20030402
Build Identifier: Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.4a) Gecko/20030402

I successfully compiled 1.4a but when compiling 1.4 I get :

Error 221: "TypeInState.h", line 71 # Member 'UpdateSelState' not declared in
class TypeInState ["TypeInState.h", line 61].
      nsresult TypeInState::UpdateSelState(nsISelection *aSelection);

and there is no UpdateSelState in 1.4a, see below for more info.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
gmake[4]: Entering directory
`/home/zvonik/temp_moz_source/mozilla/editor/libeditor/html'
nsHTMLDataTransfer.cpp
Building deps for nsHTMLDataTransfer.cpp
aCC -o nsHTMLDataTransfer.o -c -DOSTYPE=\"HP-UXB.11\" -DOSARCH=\"HP-UX\" 
-I../../../dist/include/xpcom -I../../../dist/include/string
-I../../../dist/include/dom -I../../../dist/include/layout
-I../../../dist/include/locale -I../../../dist/include/unicharutil
-I../../../dist/include/content -I../../../dist/include/txmgr
-I../../../dist/include/htmlparser -I../../../dist/include/necko
-I../../../dist/include/pref -I../../../dist/include/gfx
-I../../../dist/include/widget -I../../../dist/include/view
-I../../../dist/include/editor -I../../../dist/include
-I/home/zvonik/temp_moz_source/mozilla/dist/include/nspr     
-I../../../editor/libeditor/base -I../../../editor/libeditor/text
-I/usr/local/include/X11R6   +Z  +O1  -I/usr/local/include/X11R6   -DNDEBUG
-DTRIMMED  +O1  -I/usr/local/include/X11R6 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1
-DD_INO=d_ino -DMOZ_OJI_REQUIRE_THREAD_SAFE_ON_STARTUP=1 -DSTDC_HEADERS=1
-DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T=1
-DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1
-DHAVE_SYS_BYTEORDER_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_NL_TYPES_H=1
-DHAVE_MALLOC_H=1 -DHAVE_X11_XKBLIB_H=1 -DHAVE_SYS_STATVFS_H=1
-DHAVE_SYS_VFS_H=1 -DHAVE_SYS_MOUNT_H=1 -DNEW_H=\<new\> -DHAVE_LIBM=1
-DFUNCPROTO=15 -DHAVE_XSHM=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_STRERROR=1
-DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_STATVFS=1
-DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_NL_LANGINFO=1 -DHAVE_FLOCKFILE=1
-DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1 -DHAVE_ICONV=1
-DHAVE_ICONV_WITH_CONST_INPUT=1 -DHAVE_IOS_BINARY=1 -DHAVE_CPP_EXPLICIT=1
-DHAVE_CPP_TYPENAME=1 -DHAVE_CPP_MODERN_SPECIALIZE_TEMPLATE_SYNTAX=1
-DHAVE_CPP_PARTIAL_SPECIALIZATION=1 -DHAVE_CPP_ACCESS_CHANGING_USING=1
-DHAVE_CPP_AMBIGUITY_RESOLVING_USING=1 -DHAVE_CPP_UNAMBIGUOUS_STD_NOTEQUAL=1
-DHAVE_CPP_NEW_CASTS=1 -DHAVE_CPP_DYNAMIC_CAST_TO_VOID_PTR=1
-DNEED_CPP_UNUSED_IMPLEMENTATIONS=1 -DHAVE_I18N_LC_MESSAGES=1
-DMOZ_DEFAULT_TOOLKIT=\"gtk\" -DMOZ_WIDGET_GTK=1 -DMOZ_ENABLE_XREMOTE=1
-DMOZ_X11=1 -DMOZ_ENABLE_COREXFONTS=1 -DMOZ_EXTRA_X11CONVERTERS=1 -DOJI=1
-DIBMBIDI=1 -DACCESSIBILITY=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DMOZ_MATHML=1
-DMOZ_LOGGING=1 -DMOZ_USER_DIR=\".mozilla\" -DCPP_THROW_NEW=throw\(\)
-DMOZ_XUL=1 -DMOZ_PROFILESHARING=1 -DMOZ_DLL_SUFFIX=\".sl\" -DXP_UNIX=1
-DUNIX_ASYNC_DNS=1 -DJS_THREADSAFE=1 -DNS_PRINT_PREVIEW=1 -DNS_PRINTING=1
-DMOZILLA_VERSION=\"1.4\"  -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT
nsHTMLDataTransfer.cpp

Error 221: "TypeInState.h", line 71 # Member 'UpdateSelState' not declared in
class TypeInState ["TypeInState.h", line 61].
      nsresult TypeInState::UpdateSelState(nsISelection *aSelection);

and UpdateSelState only appears in editor/libeditor :

./html/TypeInState.cpp:nsresult TypeInState::UpdateSelState(nsISelection
*aSelection)
./html/TypeInState.h:  nsresult TypeInState::UpdateSelState(nsISelection
*aSelection);
./html/nsHTMLEditRules.cpp:     
mHTMLEditor->mTypeInState->UpdateSelState(selection);

Comment 1

15 years ago
CC'ing jfrancis@netscape.com, from bug 140357.
Assignee: mozbugs-build → jfrancis
Status: UNCONFIRMED → NEW
Component: Build Config → Editor: Core
Ever confirmed: true
Keywords: regression
QA Contact: granrose → sairuh

Comment 2

15 years ago
sounds like bug 209395

Comment 3

15 years ago
marking dupe

*** This bug has been marked as a duplicate of 209395 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.