If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[DOGFOOD] [PP]: [Regression]: Crash when opening New Msg compose.

VERIFIED FIXED in M12

Status

MailNews Core
Composition
P3
critical
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: laurel, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
This appears to be happening on NT only. Happens on fenella's and my machine,
doesn't happen on Win98 for Peter and Esther.

A crash occurs when opening a New Message compose window (plain text or html)
from messenger. Opening a reply window doesn't crash. Opening a New Message
compose from the browser window doesn't crash.

1.  Launch to messenger.
2.  Select and open either POP or IMAP account, set for either html or plaintext
compose window.
    Click New Msg.

Result:  crash occurs, I don't get Talkback coming up -- no crash info.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → laurel
(Reporter)

Updated

18 years ago
Summary: [PP] NT: [Regression]: Crash when opening New Msg compose. → [PP]: [Regression]: Crash when opening New Msg compose.
(Reporter)

Comment 1

18 years ago
I take that back.  Esther is seeing this on Win98.
I cannot reproduce on either Mac or Linux.

All using 12-08-08m12.

Updated

18 years ago
Summary: [PP]: [Regression]: Crash when opening New Msg compose. → [DOGFOOD] [PP]: [Regression]: Crash when opening New Msg compose.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Comment 2

18 years ago
Unfortunally, I don't see it on my PC. Laurel, can you give me the content of the output window when the crash
occurs. For that you need to start mozilla manually from a DOS window, don't open the mozilla icon.
(Reporter)

Comment 3

18 years ago
This is from the DOS window:

ComposeMessage from XUL
nsXULKeyListenerImpl::Init()
nsLayoutHistoryState::GetState, ERROR getting History state for the key
nsLayoutHistoryState::GetState, ERROR getting History state for the key
nsLayoutHistoryState::GetState, ERROR getting History state for the key

ComposeLoad from XUL
Compose: ComposeStartup
[preselectid=id1]
[format=0]
[type=0]
[nsIMsgIdentity: id1], [nsIMsgIdentity: id2]
Created nsEditorShell
Created editorShell
nsLayoutHistoryState::AddState OOPS!. There was already a state in the hash
table for the key
nsLayoutHistoryState::AddState OOPS!. There was already a state in the hash
table for the key
editor initialized in PLAIN TEXT mode
Attaching to WebShellWindow[_blank]
set focus on the recipient

Updated

18 years ago
Whiteboard: [PDT+]

Comment 4

18 years ago
Putting on PDT+ radar.

Comment 5

18 years ago
Interesting, this didn't happen for me on 12-08-16 build on Win32.  I'm on NT.
Can you try again?
(Reporter)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
This is now OK in the 12-08-15 build on NT. Verified on mine and fenella's
setups, since we were both crashing consistently with this morning's build.

Ready for the funny farm ... oh, already here.

Comment 7

18 years ago
Glad it's fixed :-)
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.