Image in a popup window doesn't get loaded

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Other
--
major
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: Jure Repinc (JLP), Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
I'm using Mozilla build 2003070708 on Windows XP with service pack 1.

Reproducable: always

Steps to reproduce:
1. Open Mozilla
2. Go to http://www.avtomobilizem.com/
3. Click on the picture in the right side in "NAKLJUČNA SLIKA" section

Actual results:
A popup opens but it is blank and has no enlarged picture in it.

Expected result:
A popup window should open and have the enlarged picture loaded in it.
This doesn't work in Opera either.  I get zero bytes of text/html ...


> wget -S
http://www.avtomobilizem.com/modules/gallery/image.php?image_get=gal_10/Picture0351.jpg
--16:16:22-- 
http://www.avtomobilizem.com/modules/gallery/image.php?image_get=gal_10/Picture0351.jpg
           => `image.php?image_get=gal_10/Picture0351.jpg'
Connecting to www.avtomobilizem.com:80... connected!
HTTP request sent, awaiting response... 200 OK
2 Date: Tue, 08 Jul 2003 14:19:18 GMT
3 Server: Apache/1.3.27 (Unix) mod_ssl/2.8.14 OpenSSL/0.9.7a
4 Set-Cookie: PHPSESSID=e9d163e8487c6c609f637d79966a5348; path=/
5 Expires: Thu, 19 Nov 1981 08:52:00 GMT
6 Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
7 Pragma: no-cache
8 Set-Cookie: _language=
9 Set-Cookie: _language=si; expires=Mon, 03-Apr-2006 14:19:18 GMT; path=/;
domain=avtomobilizem.com
10 Set-Cookie: _language=
11 Set-Cookie: _language=si; expires=Mon, 03-Apr-2006 14:19:18 GMT; path=/;
domain=avtomobilizem.com
12 Connection: close
13 Content-Type: text/html
14

    0K                                                        @   0.00 B/s 
Assignee: darin → other
Component: Networking → Other
OS: Windows XP → All
Product: Browser → Tech Evangelism
QA Contact: benc → other
Version: Trunk → unspecified
(Reporter)

Comment 2

15 years ago
Hm I tried the above picture. It doesn't work. But I tried another one with
direct link and they work while they don't in the popup. I also saved a page
with not working popup to local machine and tried that and the picture
downloaded and showed in the popup.

So what exactly is going on here and why is this in Tech Evengelizem?

Comment 3

15 years ago
http://www.avtomobilizem.com/modules/gallery/image.php?image_url=gal_8/Servis_Cona.jpg

loads just fine if i enter it into the URL bar of mozilla; however, it doesn't
seem to work via the javascript: URL.  perhaps there is some problem with the
JavaScript on the page.

Comment 4

15 years ago
ok, nevermind... the server seems to be really flaky.  sometimes it works,
sometimes it doesn't.  sometimes it gives an empty document, while other times
(rarely) it gives the full document.  this is definitely an evangelism bug.
(Reporter)

Comment 5

15 years ago
If this is a server problem then it also wouldn't load the page with image in
IE. But it looks like that in IE it always loads it just fine but in Mozilla it
never loads it. I always get the page with image loaded in both if I manualy
enter the address.

So if it doesn't work in Mozilla and Opera this realy could be some JavaScript
error. But could someone tell me where the error is so that I can tell the
author of the page about the problem and how to fix it.

Comment 6

15 years ago
i'm not sure why it seems to always work from IE.  but, what i noticed using
ethereal to watch the network traffic is that sometimes it gives mozilla an
empty document.  there's no indication that it is in any way the fault of
mozilla.  perhaps the server is doing some kind of useragent sniffing.
(Reporter)

Comment 7

15 years ago
I now tried setting the user agent in Mozilla and Opera to that of IE6 on
Windows XP. And they still never open the page and image. maybe I could also try
setting IE so that it represents like Mozilla, but I don't know how to do that.
Can't find the "NAKLJUČNA SLIKA" section any more.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.