Mozilla should show the NEW message count on all folders, not just inbox

RESOLVED DUPLICATE of bug 18266

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 18266
15 years ago
14 years ago

People

(Reporter: arnova, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I don't know whether this is caused by the fact the mail in folders other than
inbox is not retrieved with "Get Messages" or that the count simply isn't shown.
Only thing I can remember (i could be wrong) is that in the past mozilla would
show the "new message"-count in the folder-pane for every folder (but I could be
wrong), except the Junk folder. I would be nice (anyway) if this would work
(again) as I filter (auto-move) a lot of my incoming mail on the mailserver
itself to different folders. And now I only know that there is a new message
when it appears in the inbox. It would also be nice if this behaviour would
apply for the junk-folder so that one knows (possible) junk mail arrived.

Reproducible: Always

Steps to Reproduce:
1. Set up a filter on the mailserver to auto-move some specific mail to another
folder (than inbox).
2. "Get Messages"


Actual Results:  
Nothing happens until one actually navigates to the folder where the new message
is located.


Expected Results:  
There should be "new"-mail and the count should be visible in the folder pane
for the specific folder.
check the checkbox in the folder properties and also add in your next bug report
that you use an Imap server.


*** This bug has been marked as a duplicate of 18266 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
*** This bug has bee 
>  ma 
> ked as a duplicate of 18266 *** 
 
Faced the Same Problem with Mozilla Mail and little investigation led me to 
resolve the problem. 
 
If a user has previously used Outlook or evolution, there are chances that he 
might expect the new messages to be highlighed by default, instead of going to 
the properties of each folder and marking it to check for new messages. 
 
Should not be checking for new messages in all IMAP folders be default or made 
an option? 
It is reasonable for a user to expect so. 
 
Thanks! 
Senthil 
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.