Sending a message containing Japanese characters causes Mozilla to crash

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: farcusnz, Assigned: smontagu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

When sending a message that contains Japanese characters Mozilla crashes on
succesful completion of the send. This does not appear to be related to the
character coding (iso-2022-jp) as the crash does not occur if the message only
contains roman characters.
Problem was not evident in Mozilla 1.4rc1&2 or earlier releases that I am aware of.

Reproducible: Sometimes

Steps to Reproduce:
1.compose a message with Japanese character coding using Japanese characters.
2.Send message (smtp)
3.Mozilla crashes once send process is complete.
*** Bug 212057 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

15 years ago
I haven't been able to reproduce this. Can you try using a nightly build with
talkback so we can get some data on the crash?
(Reporter)

Comment 3

15 years ago
Over the last couple of days I haven't been able to reproduce it on the build I
was originally having trouble with. Time will tell if the problem has sorted
itself out or if it is just very sporadic. I have added talkback to my build. If
I see it again I will download a more recent build and test with that.

Comment 4

15 years ago
Please reopen if you can reproduce with 1.7 beta or newer. If you reopen please
include the talkback incident ID of the automatic crash report that's generated.
Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.