Last Comment Bug 212106 - config files and booksmarks often corrupted on OS crashes
: config files and booksmarks often corrupted on OS crashes
Status: RESOLVED DUPLICATE of bug 193749
:
Product: Core
Classification: Components
Component: Preferences: Backend (show other bugs)
: Trunk
: x86 Windows 2000
: -- critical (vote)
: ---
Assigned To: Conrad Carlen (not reading bugmail)
: sairuh (rarely reading bugmail)
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-08 16:23 PDT by Floyd D'Bird
Modified: 2003-07-08 16:44 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Floyd D'Bird 2003-07-08 16:23:51 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

I have a new network card (Sierra Wireless) that often does not shutdown
cleanly.  When this happens and requires a chkdsk/scandisk,  90% of the time the
files that are bad are mozzilas.  It seems Mozilla could use a better thought
out way to update these, or call sync more often.  I am not making changes, or
adding bookmarks so I am not sure why these files are in flux, perhaps too much
dynamic info is kept in too few files? 

Reproducible: Sometimes

Steps to Reproduce:
1. shutdown windows 2000, and have it hang
2. run scandisk
3. check found.NNN and often find mozilla droppings
Actual Results:  
bookmarks and settings are gone

Expected Results:  
These files to not be in flux when changes are not being made, updates to be done
more atomically (ie, write out a temp file and rename into place so old data is
not lost until update is complete, sync to be called etc)
Comment 1 Matthias Versen [:Matti] 2003-07-08 16:44:47 PDT

*** This bug has been marked as a duplicate of 193749 ***

Note You need to log in before you can comment on or make changes to this bug.