Closed Bug 21213 Opened 20 years ago Closed 20 years ago

[HELP WANTED][FEATURE] Auto-save compose window as draft

Categories

(MailNews Core :: Composition, enhancement, P3)

enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 16360

People

(Reporter: phil, Unassigned)

Details

(Keywords: helpwanted, Whiteboard: [HELP WANTED])

It would be nice to have an auto-save preference for the compose window, just in
case the app crashes while you're composing the message.
Summary: [HELP WANTED][FEATURE] Auto-save compose window as draft → [HELP WANTED][FEATURE] Auto-save compose window as draft
Whiteboard: [HELP WANTED]
Be nice to see that in the HTML editor, too...
cc beppe (editor eng mgr)
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 16359 ***
there might be extra work for mail compose depending on design decisions:
1) would mail compose want a separate pref?  Or just one pref to cover mail and
document composition.  I lean towards a single pref:  keep it simple, editing is
editing.
2) I don't know specifically how the save is wired up, so I don't know *where*
the mail compose draft would be saved.  Same as "save as draft", into a mail
folder?  probably.  if the underlying save code doesn't have to care because
it's already all wired up, then this is a dup.  It might take a little design
work to determine if this is really a dup or if extra work is required.
Seems like mail needs to be hooked into the saving process so we can write in
the header values, not just the body, and then encode attachments using base-64
or whatever the user has selected. Then, we need to redirect the output stream
since the Drafts folder could live on an IMAP server.

cc'ing jefft who probably understands whether this is a dup of 16359 or not.
buster -- to be safe then, should we make the 2 bugs dependent so your input
doesn't get overlooked? I certainly don't mind un-duping (if that's a word) this
one
Status: RESOLVED → REOPENED
Assignee: nobody → phil
Status: REOPENED → NEW
Depends on: 16359
assigning to phil for further assignment within the mail team.  once the editor
bug 16359 is fixed, they can wire it up in mail compose.
Assignee: phil → nobody
I'm afraid this has to stay on the [help wanted] list for now. Back to
nobody@mozilla.org
Clearing DUPLICATE resolution due to reopen.
Resolution: DUPLICATE → ---
Umm, isn't this bug #16360, filed at the same time as bug #16359?
Keywords: helpwanted
Matty, yes, I think you're right


*** This bug has been marked as a duplicate of 16360 ***
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
verified as duplicate.
Status: RESOLVED → VERIFIED
No longer depends on: 16359
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.