clicking and dragging in the middle of a completely selected address bar url doesn't select dragged over text

RESOLVED DUPLICATE of bug 87410

Status

()

Core
XUL
--
enhancement
RESOLVED DUPLICATE of bug 87410
15 years ago
10 years ago

People

(Reporter: Chris Salmon, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

If the url in the address bar has a selection, pressing the mouse button down
within the selected text and dragging, moves the selected text, instead of
creating a new selection.

When pressing the mouse button down outside of the selected text and dragging,
you change the selected text. This is the expected behaviour of a text field (as
also seen with IE's address bar).

This causes me most problems when the url is completely selected. I try to start
a new selection by clicking and dragging from the start of the section I want to
replace, only to find that (unlike IE), I am not manipulating the end of the
selection, but dragging the whole url about.

I understand that this is used to add bookmarks and favourites, but for uses
migrating to IE is potentially confusing. Perhaps you could add an 'allow url
selection dragging' option, so the behaviour could be turned off?



Reproducible: Always

Steps to Reproduce:
1. Make sure a portion of the url in the addres bar is selected
2. Press the LMB down within the selection
3. Drag the mouse to the right.

Actual Results:  
The mouse pointer changed to either indicate that I was now dragging the
selected text to another point in the url (moving the mouse pointer outside the
selected text region), or that nothing was going to happen (moving the mouse
pointer inside the selected text region) 

Expected Results:  
This is a person preference issue. I like, and am used to, IE's response, which
is to create a new text selection instead of allowing the drag-dropping of
selected pieces of the url. I have never found that a useful feature, whereas I
often wish to click on the address bar (which will then select all of the text
in the bar), then click and drag to select the piece of text I wish to edit.
I believe this is a dupe of a resolved bug, however I know exactly what you mean
(matter of fact my IE-using brother has the same problem when he uses Mozilla
and whines about it). Either way, we can't go in and put in another pref,
especially for something as trivial as this. I will look for a similar bug, but
if memory serves, this was resolved WONTFIX. 

-> XUL Widjets.
Component: Browser-General → XP Toolkit/Widgets: XUL

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 87410 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: general → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.