Can't display chinese title of mail from dtmail on solaris (zh locale)

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
16 years ago
7 months ago

People

(Reporter: Louie.Zhao, Assigned: smontagu)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Reproduce steps:
1. using zh locale on solaris 8/9
2. compose and send a mail using dtmail with chinese title and body
3. use mozilla to receive that mail

Result:
only the body can display normally, mozilla can't display chinese title.
(Reporter)

Comment 1

16 years ago
I have investigated the reason. The mail dtmail composed under zh locale is like
something below:
....
....
subject: =?zh-CN.euc?........
....
....
Content-Type: TEXT/palin; charset="zh_CN.euc"

Mozilla parse the mail header according to RFC2047, which consider "." is a
invalid char for charset. So mozilla can't fetch charset out of the mail header.

Even mozilla can get the charset, "zh_CN.euc" is not a valid charset name.
Mozilla need to convert it to "GB2312" according to "unixcharset.properties".

I delete "." from especials[] (refer to
http://lxr.mozilla.org/seamonkey/source/netwerk/mime/src/nsMIMEHeaderParamImpl.cpp#604)
and convert "zh_CN.euc" to "GB2312", mozilla work well with dtmail.

Since deleting "." from especials[] goes against RFC2047, I am not sure whether
it's safe enough.
(Reporter)

Comment 2

16 years ago
Ftang, do you have any suggestion to resolve this problem? 
Thanks very much. 

Comment 3

16 years ago
Louie:
Could you attach a raw mail message (e.g. RFC822 format) from dtmail which
contains a body encoded in "zh_CN.euc", please ?
Product: MailNews → Core
Product: Core → MailNews Core
QA Contact: marina → i18n

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.