[FIXr]Generated content with overflow:auto; declared fails

VERIFIED FIXED in mozilla1.5beta

Status

()

Core
CSS Parsing and Computation
P2
normal
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: annevk, Assigned: bz)

Tracking

Trunk
mozilla1.5beta
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030707

Testcase
http://www.annevankesteren.nl/css/testcase/generated_content.html

Mozilla doens't show the generated content and applies the text-transform on the
wrong letter which is a direct result of the first.

Reproducible: Always

Steps to Reproduce:

Actual Results:  
Mozilla renders the code with most of the style applied. The first letter of the
code is transferred to uppercase. There isn't any generated content.

Expected Results:  
There should be a block-level element with in it: "The value of the class from
the element code", followed by a "space" and then "code:". The first letter of
the classname should be in uppercase. Then there should be a linebreak and then
comes the content of the element code.
(Assignee)

Comment 1

14 years ago
So the problem seems to be that in ConstructFrameByDisplayType the
IsScrollable(aPresContext, aDisplay) case passes PR_FALSE for the
aCanHaveGeneratedContent param of ProcessChildren when calling ProcessChildren
with the scrolled frame as a parent.

Changing that to PR_TRUE makes the testcase render correctly, modulo the
::before/::first-letter problem...

Is there a good reason that param is PR_FALSE?  The cvs blame for this line is
something back in 1999, and drilling back in cvs revision history did not give
me any insight into why it was written this way.
I doubt it.
(Assignee)

Comment 3

14 years ago
Created attachment 127397 [details] [diff] [review]
proposed patch
(Assignee)

Updated

14 years ago
Attachment #127397 - Flags: superreview?(roc+moz)
Attachment #127397 - Flags: review?(roc+moz)
(Assignee)

Comment 4

14 years ago
.
Assignee: dbaron → bzbarsky
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → mozilla1.5beta
(Assignee)

Updated

14 years ago
Summary: Generated content with overflow:auto; declared fails → [FIX]Generated content with overflow:auto; declared fails
Attachment #127397 - Flags: superreview?(roc+moz)
Attachment #127397 - Flags: superreview+
Attachment #127397 - Flags: review?(roc+moz)
Attachment #127397 - Flags: review+
(Assignee)

Updated

14 years ago
Summary: [FIX]Generated content with overflow:auto; declared fails → [FIXr]Generated content with overflow:auto; declared fails
(Assignee)

Comment 5

14 years ago
Fixed for 1.5b.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

14 years ago
The content is now generated in my testcase, however the first-letter is not
turned into uppercase. That's why I reopend the bug.

UA: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

14 years ago
One issue per bug, please.  Please file a separate bug and cc me on it, ok?
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Comment 8

14 years ago
The other bug is bug 214004.
*** Bug 217868 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

14 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.