Install fails on Win2000

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Jeff Taylor, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: Mozilla 1.4.0.2003062408

Ok. Now you've done it. 1.4 doesn't install and 1.3 isn't available on your 
website anymore. I can't get to my email. What kind of QA do you have up there? 
Did you even try to install on Win2000?

At the end of the install, I get an error window that is titled "Program 
Error." In the window is the message "<process has already exited> has 
generated errors and will be closed by windows. You will need to restart the 
program. An error log is being generated."

How do I get back to 1.3? And how will I know when 1.4 is working?


Reproducible: Always

Steps to Reproduce:
1. Install 1.4 on Win2000.
2. Look at error window produced.
3. 

Actual Results:  
I was stuck without a browser and an email client. Tried to find 1.3 on the 
mozilla.org website and it's not there anymore! I'm stuck! Not a good 
experience.

Expected Results:  
Installed properly and run properly.

The these I was using on 1.3 was not the default. Doesn't 1.4 startup with the 
1.4 default so it can at least install and startup correctly?
(Reporter)

Comment 1

15 years ago
OK, I found version 1.3.1 on a nondescript link. Sorry about the attitude. I 
still don't understand why an installer wouldn't work.

Comment 2

15 years ago
I confirm this is happening for me, as well.  Under Win2k, instal appears to 
complete, but trying to run mozilla, or profile manager, gives "Mozilla.exe 
generated an error".

I looked in the application event log, and found this:

The application, mozilla.exe, generated an application error The error occurred 
on 07/09/2003 @ 23:15:32.177 The exception generated was c0000005 at address 
610F0769 (NS_NewGenericFactory) 

Looks like it dies so hard, the talk back can't even report in.
Reporter:
Are you sure that you installed in a complete empty directory and not over an
older build ?

Comment 4

15 years ago
Well, that fixed it for me.

I've always just done an uninstall, and kept the plugins through most of the
updates, but this time, an unistall was not enough.

Doing an unistall, followed by removing the directory, let it run fine now.

Thanks,
Don
Product: Browser → Seamonkey
thanks for the answer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.