Flags not thrown away on mid-air collision

RESOLVED DUPLICATE of bug 99215

Status

()

RESOLVED DUPLICATE of bug 99215
16 years ago
6 years ago

People

(Reporter: iann_bugzilla, Assigned: myk)

Tracking

Bug Flags:
blocking2.18 -

Details

(Reporter)

Description

16 years ago
If two people set the same flag on the same bug and have a mid-air collision,
the bug ends up with two requests for the same flag.
Steps to reproduce:
1. Open two views of the same bug in bugzilla
2. Set a blocking flag request on both screens
3. Submit on both screens
4. Have a mid-air collision
5. Tell bugzilla to commit anyway and throw away other information except comments

Expected result
1. Just comments from collision put onto bug

Actual result
1. Comments and flags from collision put onto bug
The description on "submit anyway, this will overwrite...." is actually a bit
misleading.  It will only overwrite changes to fields that are actually in the
bugs table, but won't overwrite anything that's stored in another table (which
includes CCs, flags, comments, etc).

There's a lot of things that need redone in mid-air collision handling....

Updated

16 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 2

15 years ago
*** Bug 238700 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Flags: blocking2.18?
This is kind of a minor thing in the grand scheme of things.  It's certainly not
dataloss, though it is duplication, and these types of problems have been around
with dependencies and everything else for ages, so it can't really be called a
regression either.  If someone manages to patch this before we branch, I'll
probably be likely to take it, but I won't hold for it.
Flags: blocking2.18? → blocking2.18-

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 99215 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.